aboutsummaryrefslogtreecommitdiff
path: root/games/barony
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-09-12 13:53:48 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-09-12 13:53:48 +0000
commitfd67293ba1a445a29956e53d9c0b8b8ce6f59777 (patch)
tree35fe689af90426e8e9744e3653fda0b019f1e830 /games/barony
parent8bf13d67b05fd65cc53ce07b07d8b5190fa063e2 (diff)
downloadports-fd67293ba1a445a29956e53d9c0b8b8ce6f59777.tar.gz
ports-fd67293ba1a445a29956e53d9c0b8b8ce6f59777.zip
games/barony: Update to 3.2.1
PR: 231109 Submitted by: maintainer Differential Revision: https://reviews.freebsd.org/D16995
Notes
Notes: svn path=/head/; revision=479601
Diffstat (limited to 'games/barony')
-rw-r--r--games/barony/Makefile14
-rw-r--r--games/barony/distinfo6
-rw-r--r--games/barony/files/barony.sh.in6
-rw-r--r--games/barony/files/patch-src_menu.cpp11
-rw-r--r--games/barony/files/pkg-message.in4
5 files changed, 21 insertions, 20 deletions
diff --git a/games/barony/Makefile b/games/barony/Makefile
index bb66fb528896..54b13b3b3aa4 100644
--- a/games/barony/Makefile
+++ b/games/barony/Makefile
@@ -2,8 +2,7 @@
PORTNAME= barony
DISTVERSIONPREFIX= v
-DISTVERSION= 3.1.4
-PORTREVISION= 1
+DISTVERSION= 3.2.1
CATEGORIES= games
MAINTAINER= devnexen@gmail.com
@@ -13,10 +12,11 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/GPL.3.0.txt
LIB_DEPENDS= libogg.so:audio/libogg \
+ libphysfs.so:devel/physfs-devel \
libpng.so:graphics/png \
libvorbisfile.so:audio/libvorbis
-USES= cmake compiler:c++11-lib openal localbase:ldflags pkgconfig
+USES= cmake compiler:c++11-lib dos2unix gl localbase:ldflags openal pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= TurningWheel
GH_PROJECT= Barony
@@ -25,19 +25,15 @@ USE_SDL= sdl2 image2 net2 ttf2
CMAKE_ON= OPENAL_ENABLED DATA_DIR
CMAKE_ARGS= -DEDITOR_EXE_NAME:STRING="barony-editor"
+DOS2UNIX_FILES= src/menu.cpp
LDFLAGS+= -Wl,--as-needed
LLD_UNSAFE= yes # cf. PR 226980
-SUB_FILES= barony.sh pkg-message
+SUB_FILES= pkg-message
PLIST_FILES= bin/barony \
bin/barony-editor \
- libexec/barony \
${DATADIR}/lang/en.ttf \
${DATADIR}/lang/en.txt
-post-install:
- ${MV} ${STAGEDIR}${PREFIX}/bin/barony ${STAGEDIR}${PREFIX}/libexec
- ${INSTALL_SCRIPT} ${WRKDIR}/barony.sh ${STAGEDIR}${PREFIX}/bin/barony
-
.include <bsd.port.mk>
diff --git a/games/barony/distinfo b/games/barony/distinfo
index b3af7d8c4f82..df72fc011e41 100644
--- a/games/barony/distinfo
+++ b/games/barony/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524914514
-SHA256 (TurningWheel-Barony-v3.1.4_GH0.tar.gz) = bcf7522636a2dc21fdda47114f8d9c0eec78ca2c41613e896310e6110fbf04c4
-SIZE (TurningWheel-Barony-v3.1.4_GH0.tar.gz) = 53299453
+TIMESTAMP = 1535897000
+SHA256 (TurningWheel-Barony-v3.2.1_GH0.tar.gz) = db12b9226c6c839a9d7636c70d1ad65a03f78b4c42a3b89c9ab6dd6b3022131a
+SIZE (TurningWheel-Barony-v3.2.1_GH0.tar.gz) = 53413992
diff --git a/games/barony/files/barony.sh.in b/games/barony/files/barony.sh.in
deleted file mode 100644
index 31b29482e289..000000000000
--- a/games/barony/files/barony.sh.in
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-# Temporary solution until the next version
-mkdir -p ~/.barony
-cd ~/.barony || { echo "Can't cd into ~/.barony" >&2; exit 1; }
-exec %%PREFIX%%/libexec/barony "$@"
diff --git a/games/barony/files/patch-src_menu.cpp b/games/barony/files/patch-src_menu.cpp
new file mode 100644
index 000000000000..079dbc5f32fa
--- /dev/null
+++ b/games/barony/files/patch-src_menu.cpp
@@ -0,0 +1,11 @@
+--- src/menu.cpp.orig 2018-09-11 19:38:08 UTC
++++ src/menu.cpp
+@@ -12266,7 +12266,7 @@ bool gamemodsClearAllMountedPaths()
+ for ( i = PHYSFS_getSearchPath(); *i != NULL; i++ )
+ {
+ std::string line = *i;
+- if ( line.compare(outputdir) != 0 && line.compare("./") != 0 ) // don't unmount the base ./ directory
++ if ( line.compare(outputdir) != 0 && line.compare(datadir) && line.compare("./") != 0 ) // don't unmount the base ./ directory
+ {
+ if ( PHYSFS_unmount(*i) == 0 )
+ {
diff --git a/games/barony/files/pkg-message.in b/games/barony/files/pkg-message.in
index e23d2a092a53..c32feb201f01 100644
--- a/games/barony/files/pkg-message.in
+++ b/games/barony/files/pkg-message.in
@@ -3,7 +3,7 @@ Barony requires the original game files from Barony: Blessed Edition
or the Steam versions of the game.
If using the GOG.com version, you should download the Linux version
-barony_cursed_edition_en_3_1_4_20342.sh and use the unzip command
+barony_cursed_edition_en_3_2_1_23267.sh and use the unzip command
line to extract the data.
The files will be in a directory named data/noarch/game. You can
@@ -13,7 +13,7 @@ permissions on the files.
The easiest way to do this is to follow these steps:
-$ unzip barony_cursed_edition_en_3_1_4_20342.sh
+$ unzip barony_cursed_edition_en_3_2_1_23267.sh
$ sudo cp -R data/noarch/game/* %%DATADIR%%
$ sudo find %%DATADIR%% -type d ! -perm 755 -exec chmod 755 {} \;