aboutsummaryrefslogtreecommitdiff
path: root/games/battletanks
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-15 13:04:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-15 13:04:18 +0000
commit5a5767edec71e06aeaa8775ab1acf5e3269e030b (patch)
treea71c2a9d6c5fe8ca7a6f72866e855808f0974643 /games/battletanks
parent2d1a99cef5b3472e847755818c3883de65e56654 (diff)
downloadports-5a5767edec71e06aeaa8775ab1acf5e3269e030b.tar.gz
ports-5a5767edec71e06aeaa8775ab1acf5e3269e030b.zip
Use vendor's installation logic for the game libraries, it works fine.
Notes
Notes: svn path=/head/; revision=339776
Diffstat (limited to 'games/battletanks')
-rw-r--r--games/battletanks/Makefile5
-rw-r--r--games/battletanks/files/patch-Install41
2 files changed, 0 insertions, 46 deletions
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index 4121734bed98..aca966ca1c36 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -41,11 +41,6 @@ pre-build:
@cd ${WRKSRC} && ${PYTHON_CMD} engine/sl08/sl08.py > engine/sl08/sl08.h
post-install:
- ${INSTALL_DATA} ${WRKSRC}/build/release/clunk/libclunk.so \
- ${WRKSRC}/build/release/engine/libbtanks_engine.so \
- ${WRKSRC}/build/release/mrt/libmrt.so \
- ${WRKSRC}/build/release/sdlx/libsdlx.so \
- ${STAGEDIR}${PREFIX}/lib
${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.6 \
${STAGEDIR}${MANPREFIX}/man/man6
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/battletanks/files/patch-Install b/games/battletanks/files/patch-Install
deleted file mode 100644
index 23c260784de7..000000000000
--- a/games/battletanks/files/patch-Install
+++ /dev/null
@@ -1,41 +0,0 @@
---- engine/SConscript.orig 2010-01-18 22:21:36.000000000 +0100
-+++ engine/SConscript 2010-01-18 22:22:58.000000000 +0100
-@@ -116,7 +116,7 @@
- if sys.platform != 'win32' and len(env['prefix']) > 0:
- Import('install_targets')
- Import('lib_dir')
-- install_targets.append(Install(lib_dir, bt))
-+# install_targets.append(Install(lib_dir, bt))
- else:
- Install('#', bt[0])
-
---- clunk/SConscript.orig 2010-01-18 22:21:36.000000000 +0100
-+++ clunk/SConscript 2010-01-18 22:23:41.000000000 +0100
-@@ -33,6 +33,6 @@
- if sys.platform != 'win32' and len(env['prefix']) > 0:
- Import('install_targets')
- Import('lib_dir')
-- install_targets.append(Install(lib_dir, clunk))
-+# install_targets.append(Install(lib_dir, clunk))
- else:
- Install('#', clunk[0])
---- mrt/SConscript.orig 2008-08-05 09:48:12.000000000 +0200
-+++ mrt/SConscript 2010-01-18 22:23:18.000000000 +0100
-@@ -23,6 +23,6 @@
- if sys.platform != 'win32' and env.has_key('prefix') and len(env['prefix']) > 0:
- Import('install_targets')
- Import('lib_dir')
-- install_targets.append(Install(lib_dir, mrt))
-+# install_targets.append(Install(lib_dir, mrt))
- else:
- Install('#', mrt[0])
---- sdlx/SConscript.orig 2010-01-18 22:21:36.000000000 +0100
-+++ sdlx/SConscript 2010-01-18 22:25:42.000000000 +0100
-@@ -57,6 +57,6 @@
- if sys.platform != 'win32' and len(env['prefix']) > 0:
- Import('install_targets')
- Import('lib_dir')
-- install_targets.append(Install(lib_dir, sdlx))
-+# install_targets.append(Install(lib_dir, sdlx))
- else:
- Install('#', sdlx[0])