aboutsummaryrefslogtreecommitdiff
path: root/games/blackshadeselite
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-22 13:00:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-06-22 13:00:04 +0000
commitd976851ec3e61775aba9c100948d7e8b78f86d56 (patch)
treeedd787d08b47ab379b0ce3ab8fc5eb2df4d62145 /games/blackshadeselite
parentbd93b4a2feb5a29208b4787fbe8418e68dcc5bbd (diff)
downloadports-d976851ec3e61775aba9c100948d7e8b78f86d56.tar.gz
ports-d976851ec3e61775aba9c100948d7e8b78f86d56.zip
- Fix build with clang 6
- Clarify GL dependency - Switch to options helpers
Notes
Notes: svn path=/head/; revision=473037
Diffstat (limited to 'games/blackshadeselite')
-rw-r--r--games/blackshadeselite/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/games/blackshadeselite/Makefile b/games/blackshadeselite/Makefile
index 499f12b32666..d40bd1ff9970 100644
--- a/games/blackshadeselite/Makefile
+++ b/games/blackshadeselite/Makefile
@@ -18,10 +18,12 @@ LIB_DEPENDS= libvorbis.so:audio/libvorbis
USES= tar:bzip2 gmake openal:al,alut
USE_SDL= sdl
-USE_GL= yes
+USE_GL= gl glu
MAKE_ARGS= CC="${CC}" CXX="${CXX}"
+CXXFLAGS+= -Wno-c++11-narrowing
+
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/blackshades
@@ -40,8 +42,10 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/objs/blackshades ${STAGEDIR}${PREFIX}/bin/
- cd ${WRKSRC} && ${COPYTREE_SHARE} Data ${STAGEDIR}${DATADIR}/
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} Data ${STAGEDIR}${DATADIR}/
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor