aboutsummaryrefslogtreecommitdiff
path: root/games/block/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-02-04 19:29:58 +0000
committerJohn Marino <marino@FreeBSD.org>2016-02-04 19:29:58 +0000
commitb83ab99a289652d697271b632d1bb59554a928de (patch)
tree863217156ebe53e90753b38ba5115fe0003b6256 /games/block/Makefile
parent93bd70a002538a6656135d572f12a24ceb77ac86 (diff)
downloadports-b83ab99a289652d697271b632d1bb59554a928de.tar.gz
ports-b83ab99a289652d697271b632d1bb59554a928de.zip
games/block: USES+=ncurses, USES+=tar, respect LDFLAGS
Also link exclusively with libncurses (not libtermcap). Also respect 80 columns.
Notes
Notes: svn path=/head/; revision=408082
Diffstat (limited to 'games/block/Makefile')
-rw-r--r--games/block/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/block/Makefile b/games/block/Makefile
index d3c2710cab86..e8760453346a 100644
--- a/games/block/Makefile
+++ b/games/block/Makefile
@@ -5,14 +5,15 @@ PORTNAME= block
PORTVERSION= 0.6
CATEGORIES= games
MASTER_SITES= SUNSITE/games/strategy
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Small text based maze game
+USES= ncurses tar:tgz
WRKSRC= ${WRKDIR}/blocks
MAKEFILE= makefile
ALL_TARGET= block bed
+MAKE_ARGS= LL="${LDFLAGS} -lncurses" CLL="${LDFLAGS} -lncurses"
post-extract:
@${RM} -f ${WRKSRC}/block
@@ -25,7 +26,8 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/bed.6 ${STAGEDIR}${MAN6PREFIX}/man/man6
@${MKDIR} ${STAGEDIR}${DATADIR}
.for file in 1 2 3 4 5 6
- ${INSTALL_DATA} ${WRKSRC}/${file}.block ${STAGEDIR}${DATADIR}/${file}.block
+ ${INSTALL_DATA} ${WRKSRC}/${file}.block \
+ ${STAGEDIR}${DATADIR}/${file}.block
.endfor
.include <bsd.port.mk>