aboutsummaryrefslogtreecommitdiff
path: root/games/blockout/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-04-15 19:29:56 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-04-15 19:29:56 +0000
commit1ee46ef011a8c5cdbf74311c15c70c808171b5fb (patch)
tree214eb342ed1dacb631337db6b1b0425eae215fcc /games/blockout/Makefile
parented4848224ef75fa4c08aa7069c0ba6116d509f32 (diff)
downloadports-1ee46ef011a8c5cdbf74311c15c70c808171b5fb.tar.gz
ports-1ee46ef011a8c5cdbf74311c15c70c808171b5fb.zip
Add .desktop entry and icon.
Notes
Notes: svn path=/head/; revision=438594
Diffstat (limited to 'games/blockout/Makefile')
-rw-r--r--games/blockout/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/games/blockout/Makefile b/games/blockout/Makefile
index 5f6ad209e75a..c5f9ba947c32 100644
--- a/games/blockout/Makefile
+++ b/games/blockout/Makefile
@@ -3,7 +3,7 @@
PORTNAME= blockout
PORTVERSION= 2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/BlockOut%20${PORTVERSION}/ \
http://www.stasyan.com/devel/distfiles/
@@ -29,6 +29,13 @@ BUILD_WRKSRC= ${WRKSRC}/BlockOut
OPTIONS_DEFINE= DOCS
+DESKTOP_ENTRIES="BlockOut" \
+ "" \
+ "${PREFIX}/share/pixmaps/block_icon.ico" \
+ "${PORTNAME}" \
+ "" \
+ ""
+
post-patch:
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/BlockOut/Utils.cpp
@@ -38,6 +45,7 @@ pre-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/BlockOut/blockout ${STAGEDIR}${PREFIX}/bin
cd ${WRKDIR}/blockout && ${COPYTREE_SHARE} "images sounds" ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/BlockOut/block_icon.ico ${STAGEDIR}${PREFIX}/share/pixmaps
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}