aboutsummaryrefslogtreecommitdiff
path: root/games/blokish
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-24 07:50:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-24 07:50:14 +0000
commitce65ce37e0e5a758b180a3b117c18bef953c8551 (patch)
treee77919f65d1b461dca5553034d6a3d7236442533 /games/blokish
parentc5a4de3c1d59efa7c6c86c3c4d1cd5ccee93aea6 (diff)
downloadports-ce65ce37e0e5a758b180a3b117c18bef953c8551.tar.gz
ports-ce65ce37e0e5a758b180a3b117c18bef953c8551.zip
Clone of the strategy board game 'Blokus'. Four players must place
as many of their 21 pieces on the board as possible while preventing others from doing the same. This is made difficult by the fact that a piece played by a player must touch another of the player's pieces, but only at their corners (a player's first piece must touch a board corner). The game is over when no player can play any new pieces. The winner is the player with the fewest & smallest pieces remaining. Bonus points are awarded for playing all pieces. Features a tweakable AI to take the place of any human players. WWW: http://blokish.sourceforge.net/ PR: ports/91961 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=154323
Diffstat (limited to 'games/blokish')
-rw-r--r--games/blokish/Makefile44
-rw-r--r--games/blokish/distinfo3
-rw-r--r--games/blokish/files/extra-patch-src-ai.h11
-rw-r--r--games/blokish/pkg-descr15
4 files changed, 73 insertions, 0 deletions
diff --git a/games/blokish/Makefile b/games/blokish/Makefile
new file mode 100644
index 000000000000..0db03e3522c4
--- /dev/null
+++ b/games/blokish/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: blokish
+# Date created: 18 Jan 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= blokish
+PORTVERSION= 0.9.3
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_src_v${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Clone of the strategy board game 'Blokus'
+
+LIB_DEPENDS= wx_base-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GL= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+
+MAKEFILE= makefile
+
+WRKSRC= ${WRKDIR}/blokish
+
+PLIST_FILES= bin/blokish
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-ai.h
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|wx-config|wxgtk2-2.6-config|' ${WRKSRC}/makefile.in ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/games/blokish/distinfo b/games/blokish/distinfo
new file mode 100644
index 000000000000..dc879ee90c7c
--- /dev/null
+++ b/games/blokish/distinfo
@@ -0,0 +1,3 @@
+MD5 (blokish_src_v0.9.3.tgz) = b8969471cb6cb4f61565225f1d269e15
+SHA256 (blokish_src_v0.9.3.tgz) = 86922d6bdcc77eb1b1bff84eaf848d44c2b959267c582b978ff93a12c4e70906
+SIZE (blokish_src_v0.9.3.tgz) = 184460
diff --git a/games/blokish/files/extra-patch-src-ai.h b/games/blokish/files/extra-patch-src-ai.h
new file mode 100644
index 000000000000..f614e9e41dbc
--- /dev/null
+++ b/games/blokish/files/extra-patch-src-ai.h
@@ -0,0 +1,11 @@
+--- src/ai.h.orig Wed Jan 4 13:39:31 2006
++++ src/ai.h Wed Jan 18 17:27:15 2006
+@@ -25,6 +25,8 @@
+ #ifndef AI_H
+ #define AI_H
+
++#include <time.h>
++#include <algo.h>
+ #include "piece.h"
+ #include "player.h"
+ #include "board.h"
diff --git a/games/blokish/pkg-descr b/games/blokish/pkg-descr
new file mode 100644
index 000000000000..06ab09e485e8
--- /dev/null
+++ b/games/blokish/pkg-descr
@@ -0,0 +1,15 @@
+Clone of the strategy board game 'Blokus'. Four players must place
+as many of their 21 pieces on the board as possible while preventing
+others from doing the same.
+
+This is made difficult by the fact that a piece played by a player
+must touch another of the player's pieces, but only at their corners
+(a player's first piece must touch a board corner).
+
+The game is over when no player can play any new pieces. The winner
+is the player with the fewest & smallest pieces remaining. Bonus
+points are awarded for playing all pieces.
+
+Features a tweakable AI to take the place of any human players.
+
+WWW: http://blokish.sourceforge.net/