aboutsummaryrefslogtreecommitdiff
path: root/games/braincurses/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-17 13:11:27 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-17 13:11:27 +0000
commit0389fa21c69ec984bd594f486d5e645b16b02a3e (patch)
treeeb89d21145cf601653e21bcf58f5f94b01ec525e /games/braincurses/Makefile
parent16a085054eb507823629fac03b4e0ced18b1b484 (diff)
downloadports-0389fa21c69ec984bd594f486d5e645b16b02a3e.tar.gz
ports-0389fa21c69ec984bd594f486d5e645b16b02a3e.zip
New port: games/braincurses
BrainCurses is a clone of the Mastermind game implemented in ncurses. PR: ports/47097 Submitted by: Michael L. Hostbaek <mich@freebsdcluster.org>
Notes
Notes: svn path=/head/; revision=73347
Diffstat (limited to 'games/braincurses/Makefile')
-rw-r--r--games/braincurses/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/braincurses/Makefile b/games/braincurses/Makefile
new file mode 100644
index 000000000000..18cf583c140b
--- /dev/null
+++ b/games/braincurses/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: braincurses
+# Date created: Wed Jan 15, 2003
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= braincurses
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= http://uhaweb.hartford.edu/hyland/derr/
+
+MAINTAINER= mich@freebsdcluster.org
+
+LDFLAGS+= -lncurses
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CXX} -c -o curses/windows.o curses/windows.cpp && \
+ ${CXX} ${CFLAGS} -c ${PORTNAME}.cpp && \
+ ${CXX} ${CFLAGS} ${LDFLAGS} -o ${PORTNAME} curses/windows.o ${PORTNAME}.o
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+.endif
+
+.include <bsd.port.mk>