aboutsummaryrefslogtreecommitdiff
path: root/games/brainparty/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-27 23:54:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-27 23:54:32 +0000
commit64107ce9d2c4d67f23a7694afc5f4f495a568722 (patch)
treed401a72d1a8740dfccf78b18bb90b6aaeab7d5fa /games/brainparty/Makefile
parentaff7b63b015bb23de06b24d07a9a24f69bf02f50 (diff)
downloadports-64107ce9d2c4d67f23a7694afc5f4f495a568722.tar.gz
ports-64107ce9d2c4d67f23a7694afc5f4f495a568722.zip
- Update to 0.61
- Add LICENSE - Switch to options helpers
Notes
Notes: svn path=/head/; revision=422835
Diffstat (limited to 'games/brainparty/Makefile')
-rw-r--r--games/brainparty/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/games/brainparty/Makefile b/games/brainparty/Makefile
index c602c65ba46e..9b439ddef9e9 100644
--- a/games/brainparty/Makefile
+++ b/games/brainparty/Makefile
@@ -2,16 +2,18 @@
# $FreeBSD$
PORTNAME= brainparty
-PORTVERSION= 0.5
-PORTREVISION= 8
+PORTVERSION= 0.61
CATEGORIES= games
-MASTER_SITES= http://www.tuxradar.com/files/brainparty/ \
+MASTER_SITES= https://launchpad.net/brainparty/trunk/${PORTVERSION}/+download/ \
http://mirror.amdmi3.ru/distfiles/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Family-friendly set of 36 puzzle games
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= gmake
USE_SDL= sdl mixer ttf gfx image
USE_GL= gl glu
@@ -29,9 +31,11 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${MKDIR} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/Content/* ${STAGEDIR}${DATADIR}/
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CREDITS ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>