aboutsummaryrefslogtreecommitdiff
path: root/games/brainparty/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-04-04 17:38:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-04-04 17:38:10 +0000
commitc1a541e10b6da4e977a1c56303ca18763254bc5e (patch)
treebd99c1f9fd4d9ff682c82dc5739770a4ca386b18 /games/brainparty/Makefile
parentf390ea6077c7f2203c80030dda537ba49703381a (diff)
downloadports-c1a541e10b6da4e977a1c56303ca18763254bc5e.tar.gz
ports-c1a541e10b6da4e977a1c56303ca18763254bc5e.zip
Conditionalize compiler flags that are specific to clang to fix errors
of the following forms on GCC-based architectures: cc1plus: error: unrecognized command line option "-Wno-c++11-narrowing" cc1plus: error: unrecognized command line option "-Wno-reserved-user-defined-literal" cc1plus: warning: unrecognized command line option '-Wno-error-narrowing' Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=497858
Diffstat (limited to 'games/brainparty/Makefile')
-rw-r--r--games/brainparty/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/brainparty/Makefile b/games/brainparty/Makefile
index 4c721be25598..887cef2ac1fe 100644
--- a/games/brainparty/Makefile
+++ b/games/brainparty/Makefile
@@ -15,11 +15,12 @@ COMMENT= Family-friendly set of 36 puzzle games
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake
+USES= compiler gmake
USE_SDL= sdl mixer ttf gfx image
USE_GL= gl glu
-CXXFLAGS+= -Wno-c++11-narrowing
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
WRKSRC= ${WRKDIR}/${PORTNAME}