aboutsummaryrefslogtreecommitdiff
path: root/games/brainparty
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-04-25 12:07:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-04-25 12:07:11 +0000
commitcc7a215393e7253699b052d411df74c323133e15 (patch)
tree8b1a14f231c6d2930b9f4592cf1d9d3ccf1f621a /games/brainparty
parentc1ea0272d599f25345352316c32a9b57bfb80a2a (diff)
downloadports-cc7a215393e7253699b052d411df74c323133e15.tar.gz
ports-cc7a215393e7253699b052d411df74c323133e15.zip
Brain Party is a fun, free puzzle game for all the family that's
made up of 36 minigames designed to push your brain to its limits by testing memory, logic, mathematics, reaction time and more! Brain Party is split into two modes: test mode gives you five minigames in a row and adds up your brain weight to see how smart you are, and practise mode lets you play your favourite minigames as often as you want. If you do well enough, there are six extra minigames that can be unlocked as well as a new game mode designed to keep you playing and enjoying your favourite games even longer. WWW: http://www.tuxradar.com/brainparty
Notes
Notes: svn path=/head/; revision=253219
Diffstat (limited to 'games/brainparty')
-rw-r--r--games/brainparty/Makefile42
-rw-r--r--games/brainparty/distinfo3
-rw-r--r--games/brainparty/files/patch-BPGame.cpp27
-rw-r--r--games/brainparty/files/patch-Makefile20
-rw-r--r--games/brainparty/pkg-descr11
-rw-r--r--games/brainparty/pkg-plist433
6 files changed, 536 insertions, 0 deletions
diff --git a/games/brainparty/Makefile b/games/brainparty/Makefile
new file mode 100644
index 000000000000..c4af88feec06
--- /dev/null
+++ b/games/brainparty/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: brainparty
+# Date created: 04 Apr 2010
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= brainparty
+PORTVERSION= 0.5
+CATEGORIES= games
+MASTER_SITES= http://www.tuxradar.com/files/brainparty/ \
+ http://mirror.amdmi3.ru/distfiles/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Family-friendly set of 36 puzzle games
+
+USE_GMAKE= yes
+USE_SDL= sdl mixer ttf gfx image
+USE_GL= gl glu
+MAKE_JOBS_SAFE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PORTDOCS= CREDITS README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|Content/|${DATADIR}/|' ${WRKSRC}/*.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Content/* ${DATADIR}/
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/brainparty/distinfo b/games/brainparty/distinfo
new file mode 100644
index 000000000000..f86c815c7b40
--- /dev/null
+++ b/games/brainparty/distinfo
@@ -0,0 +1,3 @@
+MD5 (brainparty0.5.tar.gz) = dca5314fd32fa0b0f502eec5846ff5e9
+SHA256 (brainparty0.5.tar.gz) = db373cf2657ee3cbea235fe6ef2dd6cb8f3e3651895f62e7b69d85bacad795c6
+SIZE (brainparty0.5.tar.gz) = 40660328
diff --git a/games/brainparty/files/patch-BPGame.cpp b/games/brainparty/files/patch-BPGame.cpp
new file mode 100644
index 000000000000..16b941b5eb41
--- /dev/null
+++ b/games/brainparty/files/patch-BPGame.cpp
@@ -0,0 +1,27 @@
+--- BPGame.cpp.orig 2010-03-11 03:15:34.000000000 +0300
++++ BPGame.cpp 2010-04-04 05:56:27.000000000 +0400
+@@ -1295,7 +1295,7 @@
+ NumUnlockedGames = 0;
+
+ ifstream ifs;
+- ifs.open(".brainparty");
++ ifs.open((string(getenv("HOME")) + "/.brainparty").c_str());
+
+ FirstRun = false;
+
+@@ -1426,7 +1426,7 @@
+
+ void BPGame::SaveSettings() {
+ ofstream savefile;
+- savefile.open(".brainparty");
++ savefile.open((string(getenv("HOME")) + "/.brainparty").c_str());
+ savefile << EnableSound << endl;
+ savefile << EnableMusic << endl;
+ savefile << endl;
+@@ -2407,4 +2407,4 @@
+ Colour* BPGame::ColorLerp(Colour* from, Colour* to, float amount) {
+ Colour* col = new Colour(Lerp(from->R, to->R, amount), Lerp(from->G, to->G, amount), Lerp(from->B, to->B, amount), Lerp(from->A, to->A, amount));
+ return col;
+-}
+\ No newline at end of file
++}
diff --git a/games/brainparty/files/patch-Makefile b/games/brainparty/files/patch-Makefile
new file mode 100644
index 000000000000..9a20c808c501
--- /dev/null
+++ b/games/brainparty/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2010-03-02 16:42:51.000000000 +0300
++++ Makefile 2010-04-04 05:36:14.000000000 +0400
+@@ -11,14 +11,14 @@
+ # to compile on OS X you need to include this Objective C file
+ OSXCOMPAT = SDLMain.m
+ else
+- INCLUDES = `sdl-config --cflags` -I/usr/X11R6/include
++ INCLUDES = `sdl-config --cflags`
+ LIBS = `sdl-config --libs` -lGL -lGLU -lSDL_mixer -lSDL_ttf -lSDL_gfx -lSDL_image
+- CXXFLAGS = -g -c -Wno-deprecated
++ CXXFLAGS += -c -Wno-deprecated
+ OSXCOMPAT =
+ endif
+
+ # object files have corresponding source files
+-CXX = g++
++CXX ?= g++
+
+ all: brainparty
+
diff --git a/games/brainparty/pkg-descr b/games/brainparty/pkg-descr
new file mode 100644
index 000000000000..2f1440c1eebd
--- /dev/null
+++ b/games/brainparty/pkg-descr
@@ -0,0 +1,11 @@
+Brain Party is a fun, free puzzle game for all the family that's
+made up of 36 minigames designed to push your brain to its limits
+by testing memory, logic, mathematics, reaction time and more! Brain
+Party is split into two modes: test mode gives you five minigames
+in a row and adds up your brain weight to see how smart you are,
+and practise mode lets you play your favourite minigames as often
+as you want. If you do well enough, there are six extra minigames
+that can be unlocked as well as a new game mode designed to keep
+you playing and enjoying your favourite games even longer.
+
+WWW: http://www.tuxradar.com/brainparty
diff --git a/games/brainparty/pkg-plist b/games/brainparty/pkg-plist
new file mode 100644
index 000000000000..55dbdf3c9111
--- /dev/null
+++ b/games/brainparty/pkg-plist
@@ -0,0 +1,433 @@
+bin/brainparty
+%%DATADIR%%/1.png
+%%DATADIR%%/2.png
+%%DATADIR%%/3.png
+%%DATADIR%%/a.png
+%%DATADIR%%/ambient.ogg
+%%DATADIR%%/arrow_down.png
+%%DATADIR%%/arrow_left.png
+%%DATADIR%%/arrow_right.png
+%%DATADIR%%/arrow_up.png
+%%DATADIR%%/b.png
+%%DATADIR%%/baa.wav
+%%DATADIR%%/baa2.wav
+%%DATADIR%%/baa3.wav
+%%DATADIR%%/back_arrow.png
+%%DATADIR%%/ball.png
+%%DATADIR%%/balloon_black.png
+%%DATADIR%%/balloon_blue.png
+%%DATADIR%%/balloon_green.png
+%%DATADIR%%/balloon_pop.wav
+%%DATADIR%%/balloon_purple.png
+%%DATADIR%%/balloon_red.png
+%%DATADIR%%/beep_hi.wav
+%%DATADIR%%/bg_results.png
+%%DATADIR%%/bg_results2.png
+%%DATADIR%%/bg_test.png
+%%DATADIR%%/block_blue.png
+%%DATADIR%%/block_grey.png
+%%DATADIR%%/block_red.png
+%%DATADIR%%/bombhunt.png
+%%DATADIR%%/bottombar.png
+%%DATADIR%%/box_1.png
+%%DATADIR%%/box_10.png
+%%DATADIR%%/box_11.png
+%%DATADIR%%/box_12.png
+%%DATADIR%%/box_13.png
+%%DATADIR%%/box_14.png
+%%DATADIR%%/box_15.png
+%%DATADIR%%/box_16.png
+%%DATADIR%%/box_2.png
+%%DATADIR%%/box_3.png
+%%DATADIR%%/box_4.png
+%%DATADIR%%/box_5.png
+%%DATADIR%%/box_6.png
+%%DATADIR%%/box_7.png
+%%DATADIR%%/box_8.png
+%%DATADIR%%/box_9.png
+%%DATADIR%%/box_question.png
+%%DATADIR%%/bpsays.png
+%%DATADIR%%/bpsays_choosing.png
+%%DATADIR%%/brainparty.png
+%%DATADIR%%/brainrace.ogg
+%%DATADIR%%/bubble.wav
+%%DATADIR%%/bubbletrouble.png
+%%DATADIR%%/c.png
+%%DATADIR%%/card_1.png
+%%DATADIR%%/card_1_48.png
+%%DATADIR%%/card_2.png
+%%DATADIR%%/card_2_48.png
+%%DATADIR%%/card_3.png
+%%DATADIR%%/card_3_48.png
+%%DATADIR%%/card_4.png
+%%DATADIR%%/card_4_48.png
+%%DATADIR%%/card_5.png
+%%DATADIR%%/card_5_48.png
+%%DATADIR%%/card_6.png
+%%DATADIR%%/card_6_48.png
+%%DATADIR%%/card_7.png
+%%DATADIR%%/card_7_48.png
+%%DATADIR%%/card_8.png
+%%DATADIR%%/card_8_48.png
+%%DATADIR%%/card_blank.png
+%%DATADIR%%/card_flip.wav
+%%DATADIR%%/card_flip2.wav
+%%DATADIR%%/card_unknown.png
+%%DATADIR%%/cardmatch.png
+%%DATADIR%%/checkers1.png
+%%DATADIR%%/checkers2.png
+%%DATADIR%%/chekolake.ogg
+%%DATADIR%%/circle_handle.png
+%%DATADIR%%/circlering.png
+%%DATADIR%%/click.wav
+%%DATADIR%%/clouds.png
+%%DATADIR%%/connex.png
+%%DATADIR%%/correct.png
+%%DATADIR%%/correct.wav
+%%DATADIR%%/d.png
+%%DATADIR%%/die_1.png
+%%DATADIR%%/die_2.png
+%%DATADIR%%/die_3.png
+%%DATADIR%%/die_4.png
+%%DATADIR%%/doublecircle.png
+%%DATADIR%%/doubleemptycircle.png
+%%DATADIR%%/down.wav
+%%DATADIR%%/e.png
+%%DATADIR%%/electricity.ogg
+%%DATADIR%%/emptycircle.png
+%%DATADIR%%/explosion.wav
+%%DATADIR%%/f.png
+%%DATADIR%%/filledcircle.png
+%%DATADIR%%/firstrun.png
+%%DATADIR%%/flashcounting.png
+%%DATADIR%%/flashlight.png
+%%DATADIR%%/freesans.ttf
+%%DATADIR%%/frog.png
+%%DATADIR%%/g.png
+%%DATADIR%%/gem1.png
+%%DATADIR%%/gem1_40.png
+%%DATADIR%%/gem1_hi_40.png
+%%DATADIR%%/gem1_small.png
+%%DATADIR%%/gem2.png
+%%DATADIR%%/gem2_40.png
+%%DATADIR%%/gem2_hi_40.png
+%%DATADIR%%/gem2_small.png
+%%DATADIR%%/gem3.png
+%%DATADIR%%/gem3_40.png
+%%DATADIR%%/gem3_hi_40.png
+%%DATADIR%%/gem3_small.png
+%%DATADIR%%/gem4.png
+%%DATADIR%%/gem4_40.png
+%%DATADIR%%/gem4_hi_40.png
+%%DATADIR%%/gem4_small.png
+%%DATADIR%%/gem5.png
+%%DATADIR%%/gem5_40.png
+%%DATADIR%%/gem5_hi_40.png
+%%DATADIR%%/gem5_small.png
+%%DATADIR%%/gem6.png
+%%DATADIR%%/gem6_40.png
+%%DATADIR%%/gem6_hi_40.png
+%%DATADIR%%/gem6_small.png
+%%DATADIR%%/gem7.png
+%%DATADIR%%/gem7_40.png
+%%DATADIR%%/gem7_hi_40.png
+%%DATADIR%%/gem7_small.png
+%%DATADIR%%/gem8.png
+%%DATADIR%%/gem8_40.png
+%%DATADIR%%/gem8_hi_40.png
+%%DATADIR%%/gem8_small.png
+%%DATADIR%%/gem_select.wav
+%%DATADIR%%/glass_break.wav
+%%DATADIR%%/green_cup.png
+%%DATADIR%%/gun1.wav
+%%DATADIR%%/gun2.wav
+%%DATADIR%%/h.png
+%%DATADIR%%/happy_ring.wav
+%%DATADIR%%/help.png
+%%DATADIR%%/highway.ogg
+%%DATADIR%%/history.png
+%%DATADIR%%/hudzillagames.png
+%%DATADIR%%/i.png
+%%DATADIR%%/icon.bmp
+%%DATADIR%%/iqtest.png
+%%DATADIR%%/j.png
+%%DATADIR%%/jewelflip.png
+%%DATADIR%%/jewelflip_bottombar.png
+%%DATADIR%%/jeweljam.png
+%%DATADIR%%/k.png
+%%DATADIR%%/l.png
+%%DATADIR%%/lensflare.png
+%%DATADIR%%/light_off.png
+%%DATADIR%%/light_on.png
+%%DATADIR%%/lively.ogg
+%%DATADIR%%/loading.png
+%%DATADIR%%/m.png
+%%DATADIR%%/marble_blue.png
+%%DATADIR%%/marble_blue40.png
+%%DATADIR%%/marble_green.png
+%%DATADIR%%/marble_green40.png
+%%DATADIR%%/marble_purple.png
+%%DATADIR%%/marble_purple40.png
+%%DATADIR%%/marble_red.png
+%%DATADIR%%/marble_red40.png
+%%DATADIR%%/marble_yellow.png
+%%DATADIR%%/marble_yellow40.png
+%%DATADIR%%/marbledrop.png
+%%DATADIR%%/memoryblox.png
+%%DATADIR%%/memorybox.png
+%%DATADIR%%/memorymaths.png
+%%DATADIR%%/memorymaths_remember.png
+%%DATADIR%%/menu_brainboost.png
+%%DATADIR%%/menu_credits.png
+%%DATADIR%%/menu_help.png
+%%DATADIR%%/menu_main.png
+%%DATADIR%%/menu_marathonmode.png
+%%DATADIR%%/menu_options.png
+%%DATADIR%%/menu_play.png
+%%DATADIR%%/menu_practise.png
+%%DATADIR%%/menu_practise_hider.png
+%%DATADIR%%/meow.wav
+%%DATADIR%%/minesweep.png
+%%DATADIR%%/minesweep_bombtile.png
+%%DATADIR%%/minesweep_tile.png
+%%DATADIR%%/minigame_balloonblaster.png
+%%DATADIR%%/minigame_bombhunt.png
+%%DATADIR%%/minigame_bpsays.png
+%%DATADIR%%/minigame_bubbletrouble.png
+%%DATADIR%%/minigame_cardmatch.png
+%%DATADIR%%/minigame_connex.png
+%%DATADIR%%/minigame_cupsnballs.png
+%%DATADIR%%/minigame_flashcounting.png
+%%DATADIR%%/minigame_flashlight.png
+%%DATADIR%%/minigame_iqtest.png
+%%DATADIR%%/minigame_jewelflip.png
+%%DATADIR%%/minigame_jeweljam.png
+%%DATADIR%%/minigame_marbledrop.png
+%%DATADIR%%/minigame_memoryblox.png
+%%DATADIR%%/minigame_memorybox.png
+%%DATADIR%%/minigame_memorymaths.png
+%%DATADIR%%/minigame_minesweep.png
+%%DATADIR%%/minigame_moonjump.png
+%%DATADIR%%/minigame_nextinline.png
+%%DATADIR%%/minigame_numbersnake.png
+%%DATADIR%%/minigame_oddoneout.png
+%%DATADIR%%/minigame_patchmatch.png
+%%DATADIR%%/minigame_perfectpaths.png
+%%DATADIR%%/minigame_routefinder.png
+%%DATADIR%%/minigame_rps.png
+%%DATADIR%%/minigame_scrambled.png
+%%DATADIR%%/minigame_setfinder.png
+%%DATADIR%%/minigame_sharpshooter.png
+%%DATADIR%%/minigame_shortcircuitsudoku.png
+%%DATADIR%%/minigame_shufflepuzzler.png
+%%DATADIR%%/minigame_symboliclogic.png
+%%DATADIR%%/minigame_teetertotter.png
+%%DATADIR%%/minigame_underthehat.png
+%%DATADIR%%/minigame_unknown.png
+%%DATADIR%%/minigame_untangler.png
+%%DATADIR%%/moonjump1.png
+%%DATADIR%%/moonjump2.png
+%%DATADIR%%/moonjump3.png
+%%DATADIR%%/moonjump4.png
+%%DATADIR%%/moonjump5.png
+%%DATADIR%%/moonjump6.png
+%%DATADIR%%/morningwave.ogg
+%%DATADIR%%/mouse_click.wav
+%%DATADIR%%/music_off.png
+%%DATADIR%%/n.png
+%%DATADIR%%/nevertoolate.ogg
+%%DATADIR%%/nextinline.png
+%%DATADIR%%/numbersnake.png
+%%DATADIR%%/numbersnake_black.png
+%%DATADIR%%/o.png
+%%DATADIR%%/oddoneout.png
+%%DATADIR%%/ok.png
+%%DATADIR%%/p.png
+%%DATADIR%%/paper.png
+%%DATADIR%%/patch1.png
+%%DATADIR%%/patch10.png
+%%DATADIR%%/patch11.png
+%%DATADIR%%/patch12.png
+%%DATADIR%%/patch13.png
+%%DATADIR%%/patch14.png
+%%DATADIR%%/patch15.png
+%%DATADIR%%/patch16.png
+%%DATADIR%%/patch17.png
+%%DATADIR%%/patch18.png
+%%DATADIR%%/patch19.png
+%%DATADIR%%/patch2.png
+%%DATADIR%%/patch20.png
+%%DATADIR%%/patch21.png
+%%DATADIR%%/patch22.png
+%%DATADIR%%/patch23.png
+%%DATADIR%%/patch24.png
+%%DATADIR%%/patch25.png
+%%DATADIR%%/patch26.png
+%%DATADIR%%/patch27.png
+%%DATADIR%%/patch28.png
+%%DATADIR%%/patch29.png
+%%DATADIR%%/patch3.png
+%%DATADIR%%/patch30.png
+%%DATADIR%%/patch31.png
+%%DATADIR%%/patch32.png
+%%DATADIR%%/patch33.png
+%%DATADIR%%/patch34.png
+%%DATADIR%%/patch35.png
+%%DATADIR%%/patch36.png
+%%DATADIR%%/patch37.png
+%%DATADIR%%/patch38.png
+%%DATADIR%%/patch39.png
+%%DATADIR%%/patch4.png
+%%DATADIR%%/patch40.png
+%%DATADIR%%/patch41.png
+%%DATADIR%%/patch42.png
+%%DATADIR%%/patch43.png
+%%DATADIR%%/patch44.png
+%%DATADIR%%/patch45.png
+%%DATADIR%%/patch46.png
+%%DATADIR%%/patch47.png
+%%DATADIR%%/patch48.png
+%%DATADIR%%/patch49.png
+%%DATADIR%%/patch5.png
+%%DATADIR%%/patch50.png
+%%DATADIR%%/patch51.png
+%%DATADIR%%/patch52.png
+%%DATADIR%%/patch53.png
+%%DATADIR%%/patch54.png
+%%DATADIR%%/patch55.png
+%%DATADIR%%/patch56.png
+%%DATADIR%%/patch57.png
+%%DATADIR%%/patch58.png
+%%DATADIR%%/patch59.png
+%%DATADIR%%/patch6.png
+%%DATADIR%%/patch7.png
+%%DATADIR%%/patch8.png
+%%DATADIR%%/patch9.png
+%%DATADIR%%/patchmatch.png
+%%DATADIR%%/perfect.png
+%%DATADIR%%/perfectpaths.png
+%%DATADIR%%/pp_1_hi.png
+%%DATADIR%%/pp_1_lo.png
+%%DATADIR%%/pp_3_hi.png
+%%DATADIR%%/pp_3_lo.png
+%%DATADIR%%/pp_5_hi.png
+%%DATADIR%%/pp_5_lo.png
+%%DATADIR%%/pp_7_hi.png
+%%DATADIR%%/pp_7_lo.png
+%%DATADIR%%/pp_9_hi.png
+%%DATADIR%%/pp_9_lo.png
+%%DATADIR%%/professor.ogg
+%%DATADIR%%/professor_talk.png
+%%DATADIR%%/propeller.png
+%%DATADIR%%/propeller_bad.png
+%%DATADIR%%/puff.png
+%%DATADIR%%/qu.png
+%%DATADIR%%/quit_test.png
+%%DATADIR%%/r.png
+%%DATADIR%%/red_cross.png
+%%DATADIR%%/red_cup.png
+%%DATADIR%%/remember.png
+%%DATADIR%%/result.wav
+%%DATADIR%%/results.ogg
+%%DATADIR%%/results_bronze.png
+%%DATADIR%%/results_bronze_90.png
+%%DATADIR%%/results_fail.png
+%%DATADIR%%/results_fail_90.png
+%%DATADIR%%/results_gold.png
+%%DATADIR%%/results_gold_90.png
+%%DATADIR%%/results_platinum.png
+%%DATADIR%%/results_platinum_90.png
+%%DATADIR%%/results_silver.png
+%%DATADIR%%/results_silver_90.png
+%%DATADIR%%/rock.png
+%%DATADIR%%/rockpaperscissors.png
+%%DATADIR%%/rockpaperscissors_loses.png
+%%DATADIR%%/routefinder.png
+%%DATADIR%%/s.png
+%%DATADIR%%/scissors.png
+%%DATADIR%%/scrambled.png
+%%DATADIR%%/secret_hi.png
+%%DATADIR%%/secret_lo.png
+%%DATADIR%%/selected48.png
+%%DATADIR%%/set_circle_blue_empty.png
+%%DATADIR%%/set_circle_blue_filled.png
+%%DATADIR%%/set_circle_blue_stripy.png
+%%DATADIR%%/set_circle_green_empty.png
+%%DATADIR%%/set_circle_green_filled.png
+%%DATADIR%%/set_circle_green_stripy.png
+%%DATADIR%%/set_circle_red_empty.png
+%%DATADIR%%/set_circle_red_filled.png
+%%DATADIR%%/set_circle_red_stripy.png
+%%DATADIR%%/set_square_blue_empty.png
+%%DATADIR%%/set_square_blue_filled.png
+%%DATADIR%%/set_square_blue_stripy.png
+%%DATADIR%%/set_square_green_empty.png
+%%DATADIR%%/set_square_green_filled.png
+%%DATADIR%%/set_square_green_stripy.png
+%%DATADIR%%/set_square_red_empty.png
+%%DATADIR%%/set_square_red_filled.png
+%%DATADIR%%/set_square_red_stripy.png
+%%DATADIR%%/set_triangle_blue_empty.png
+%%DATADIR%%/set_triangle_blue_filled.png
+%%DATADIR%%/set_triangle_blue_stripy.png
+%%DATADIR%%/set_triangle_green_empty.png
+%%DATADIR%%/set_triangle_green_filled.png
+%%DATADIR%%/set_triangle_green_stripy.png
+%%DATADIR%%/set_triangle_red_empty.png
+%%DATADIR%%/set_triangle_red_filled.png
+%%DATADIR%%/set_triangle_red_stripy.png
+%%DATADIR%%/setfinder.png
+%%DATADIR%%/sharpshooter.png
+%%DATADIR%%/sheep_left.png
+%%DATADIR%%/sheep_right.png
+%%DATADIR%%/shortcircuitsudoku.png
+%%DATADIR%%/shufflepuzzler.png
+%%DATADIR%%/shufflepuzzler1.png
+%%DATADIR%%/shufflepuzzler2.png
+%%DATADIR%%/shufflepuzzler3.png
+%%DATADIR%%/shufflepuzzler4.png
+%%DATADIR%%/shufflepuzzler5.png
+%%DATADIR%%/shufflepuzzler6.png
+%%DATADIR%%/shufflepuzzler7.png
+%%DATADIR%%/shufflepuzzler8.png
+%%DATADIR%%/shufflepuzzler9.png
+%%DATADIR%%/slide.wav
+%%DATADIR%%/slingshot.png
+%%DATADIR%%/soft_boom.wav
+%%DATADIR%%/sound_off.png
+%%DATADIR%%/star_bright.png
+%%DATADIR%%/star_dark.png
+%%DATADIR%%/star_medium.png
+%%DATADIR%%/starmarch.ogg
+%%DATADIR%%/stars_glow.png
+%%DATADIR%%/strangerdanger.png
+%%DATADIR%%/strangerdanger_remember.png
+%%DATADIR%%/swoosh_long.wav
+%%DATADIR%%/symboliclogic.png
+%%DATADIR%%/t.png
+%%DATADIR%%/target.png
+%%DATADIR%%/teststatus1.png
+%%DATADIR%%/teststatus2.png
+%%DATADIR%%/teststatus3.png
+%%DATADIR%%/teststatus4.png
+%%DATADIR%%/teststatus5.png
+%%DATADIR%%/theme.ogg
+%%DATADIR%%/u.png
+%%DATADIR%%/v.png
+%%DATADIR%%/w.png
+%%DATADIR%%/whack.wav
+%%DATADIR%%/whichisstranger.png
+%%DATADIR%%/white.png
+%%DATADIR%%/white_circle.png
+%%DATADIR%%/wordlist.txt
+%%DATADIR%%/wordsmash_bottom.png
+%%DATADIR%%/wordsmash_top.png
+%%DATADIR%%/wrong.png
+%%DATADIR%%/wrong.wav
+%%DATADIR%%/wrong2.wav
+%%DATADIR%%/wrong3.wav
+%%DATADIR%%/x.png
+%%DATADIR%%/y.png
+%%DATADIR%%/z.png
+%%DATADIR%%/zap.wav
+@dirrm %%DATADIR%%