aboutsummaryrefslogtreecommitdiff
path: root/games/brogue
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-08-02 16:46:13 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-08-02 20:18:43 +0000
commitbf71474213f3d7147d34deebfcd2e76604bb5939 (patch)
treee3b7f82aeb53ab9b41f9eecf1b05fcef021c1c63 /games/brogue
parent7a411f42160089e8abbe4fe2dba6eb251b860996 (diff)
downloadports-bf71474213f3d7147d34deebfcd2e76604bb5939.tar.gz
ports-bf71474213f3d7147d34deebfcd2e76604bb5939.zip
games/brogue: (New) Much-loved minimalist roguelike game (community edition)
PR: 257567
Diffstat (limited to 'games/brogue')
-rw-r--r--games/brogue/Makefile65
-rw-r--r--games/brogue/distinfo3
-rw-r--r--games/brogue/files/brogue.desktop.in13
-rwxr-xr-xgames/brogue/files/brogue.sh.in7
-rw-r--r--games/brogue/pkg-descr19
5 files changed, 107 insertions, 0 deletions
diff --git a/games/brogue/Makefile b/games/brogue/Makefile
new file mode 100644
index 000000000000..cd508ccfa9d1
--- /dev/null
+++ b/games/brogue/Makefile
@@ -0,0 +1,65 @@
+PORTNAME= brogue
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.10
+CATEGORIES= games
+
+MAINTAINER= fuz@fuz.su
+COMMENT= Much-loved minimalist roguelike game (community edition)
+
+LICENSE= AGPLv3+ CC-BY-SA-4.0
+LICENSE_COMB= multi
+LICENSE_FILE_AGPLv3+ = ${WRKSRC}/LICENSE.txt
+LICENSE_FILE_CC-BY-SA-4.0= ${WRKSRC}/bin/assets/LICENSE.txt
+
+FLAVORS= x11 nox11
+FLAVOR?= ${FLAVORS:[1]}
+nox11_PKGNAMESUFFIX= -nox11
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= tmewett
+GH_PROJECT= BrogueCE
+
+.if ${FLAVOR} == x11
+USES+= sdl
+USE_SDL= sdl2 image2
+.endif
+
+MAKE_ARGS= DATADIR=${DATADIR} \
+ RELEASE=YES \
+ GRAPHICS=${${FLAVOR:U} == x11:?YES:NO}
+ALL_TARGET= bin/brogue
+SUB_FILES= brogue.desktop brogue.sh
+PLIST_SUB= DISTVERSION=${DISTVERSION}
+
+PLIST_FILES= bin/brogue \
+ libexec/brogue \
+ share/applications/brogue.desktop
+PORTDATA= assets/LICENSE.txt \
+ assets/tiles.bin \
+ assets/icon.png \
+ assets/tiles.png \
+ keymap.txt
+
+OPTIONS_DEFINE= DEBUG NCURSES WEBUI
+OPTIONS_DEFAULT= NCURSES WEBUI
+DEBUG_MAKE_ARGS= DEBUG=YES
+DEBUG_MAKE_ARGS_OFF= DEBUG=NO
+NCURSES_USES= ncurses
+NCURSES_MAKE_ARGS= TERMINAL=YES
+NCURSES_MAKE_ARGS_OFF= TERMINAL=NO
+WEBUI_MAKE_ARGS= WEBUI=YES
+WEBUI_MAKE_ARGS_OFF= WEBUI=NO
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/opt/brogue,${DATADIR},' ${WRKSRC}/linux/brogue-multiuser.sh
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/brogue ${STAGEDIR}${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKDIR}/brogue.sh ${STAGEDIR}${PREFIX}/bin/brogue
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/keymap.txt ${STAGEDIR}${DATADIR}
+ ${CP} -r ${WRKSRC}/bin/assets ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/brogue.desktop ${STAGEDIR}${PREFIX}/share/applications
+
+.include <bsd.port.mk>
diff --git a/games/brogue/distinfo b/games/brogue/distinfo
new file mode 100644
index 000000000000..1d9072410624
--- /dev/null
+++ b/games/brogue/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1627915047
+SHA256 (tmewett-BrogueCE-v1.10_GH0.tar.gz) = 31af277940f784a6809ff08a2420b8122b9e15f2bfdf985d7678b69fc12d8e6b
+SIZE (tmewett-BrogueCE-v1.10_GH0.tar.gz) = 1159270
diff --git a/games/brogue/files/brogue.desktop.in b/games/brogue/files/brogue.desktop.in
new file mode 100644
index 000000000000..412c343db1a8
--- /dev/null
+++ b/games/brogue/files/brogue.desktop.in
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=%%DISTVERSION%%
+Type=Application
+Name=Brogue
+GenericName=Roguelike
+Comment=Brave the Dungeons of Doom!
+Comment[de]=Meistere die Dungeons der Verdammnis!
+Comment[ru]=Бросьте вызов Подземельям Погибели!
+Exec=%%PREFIX%%/bin/brogue
+Path=%%DATADIR%%
+Icon=%%DATADIR%%/assets/icon.png
+Terminal=false
+Categories=Game;
diff --git a/games/brogue/files/brogue.sh.in b/games/brogue/files/brogue.sh.in
new file mode 100755
index 000000000000..6aa940ae2414
--- /dev/null
+++ b/games/brogue/files/brogue.sh.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+set -e
+userdir="${XDG_DATA_HOME:-$HOME/.local/share}/Brogue"
+mkdir -p "$userdir"
+cd "$userdir"
+exec %%PREFIX%%/libexec/brogue "$@"
diff --git a/games/brogue/pkg-descr b/games/brogue/pkg-descr
new file mode 100644
index 000000000000..6f9f00bd3283
--- /dev/null
+++ b/games/brogue/pkg-descr
@@ -0,0 +1,19 @@
+Countless adventurers before you have descended this torch-lit
+staircase, seeking the promised riches below. As you reach the bottom
+and step into the wide cavern, the doors behind you seal with a powerful
+magic...
+
+ Welcome to the Dungeons of Doom!
+
+Brogue is a single-player strategy game set in the halls of a mysterious
+and randomly-generated dungeon. The objective is simple enough --
+retrieve the fabled Amulet of Yendor from the 26th level -- but the
+dungeon is riddled with danger. Horrifying creatures and devious,
+trap-ridden terrain await. Yet it is also riddled with weapons, potions,
+and artifacts of forgotten power. Survival demands strength and cunning
+in equal measure as you descend, making the most of what the dungeon
+gives you. You will make sacrifices, narrow escapes, and maybe even some
+friends along the way -- but will you be one of the lucky few to return
+alive?
+
+WWW: https://sites.google.com/site/broguegame/