aboutsummaryrefslogtreecommitdiff
path: root/games/bubble-chains
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-08-20 18:09:28 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-08-20 18:09:28 +0000
commit64c3be345f72780e611280dd3a1b98e46c5e8583 (patch)
tree5577c7e5a7a9c705339a6727b4f30f361bd7d8af /games/bubble-chains
parentdcffed9c215e37872112340a30420628dc132c91 (diff)
downloadports-64c3be345f72780e611280dd3a1b98e46c5e8583.tar.gz
ports-64c3be345f72780e611280dd3a1b98e46c5e8583.zip
- port requires data installation
- use portname variable for plist - optionsNG on DOCS PR: 170722 Submitted by: maintainer, nemysis@gmx.ch
Notes
Notes: svn path=/head/; revision=302826
Diffstat (limited to 'games/bubble-chains')
-rw-r--r--games/bubble-chains/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/games/bubble-chains/Makefile b/games/bubble-chains/Makefile
index f153410eec85..011635e3a22e 100644
--- a/games/bubble-chains/Makefile
+++ b/games/bubble-chains/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bubble-chains
PORTVERSION= 0.1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://bubble-chains.sintegrial.com/files/
DISTNAME= chains-${DISTVERSION}
@@ -31,9 +31,9 @@ USE_QT4= moc_build qmake_build rcc_build uic_build iconengines imageformats \
MAKE_JOBS_SAFE= yes
-PLIST_FILES= bin/bubble-chains \
- share/pixmaps/bubble-chains.ico \
- share/pixmaps/bubble-chains.png
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.ico \
+ share/pixmaps/${PORTNAME}.png
PLIST_DIRSTRY= share/applications
PORTDATA= *
@@ -50,6 +50,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/games/chains|${DATADIR}|' \
${WRKSRC}/main.cpp ${WRKSRC}/Game.pro
+.include <bsd.port.options.mk>
+
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} ${QMAKEFLAGS}
@@ -58,20 +60,18 @@ do-install:
# Executable
${INSTALL_PROGRAM} ${WRKSRC}/bin/chains ${PREFIX}/bin/${PORTNAME}
+# Data
+ ${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${DATADIR})
+
# Pixmaps and Desktop
${INSTALL_DATA} ${WRKSRC}/images/logo.png \
${PREFIX}/share/pixmaps/${PORTNAME}.png
${INSTALL_DATA} ${WRKSRC}/icon.ico \
${PREFIX}/share/pixmaps/${PORTNAME}.ico
-# Data
-.if !defined (NOPORTDATA)
- ${MKDIR} ${DATADIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${DATADIR})
-.endif
-
# Documentation
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif