aboutsummaryrefslogtreecommitdiff
path: root/games/bygfoot
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-11-29 18:22:32 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-11-29 18:22:32 +0000
commitedb7229dd444037f6015d4a7d1c93eade4ed41f0 (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /games/bygfoot
parentb134ca1eb84846189b4cdfa7ab624072ad1aebb6 (diff)
downloadports-edb7229dd444037f6015d4a7d1c93eade4ed41f0.tar.gz
ports-edb7229dd444037f6015d4a7d1c93eade4ed41f0.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=373636
Diffstat (limited to 'games/bygfoot')
-rw-r--r--games/bygfoot/Makefile4
-rw-r--r--games/bygfoot/files/patch-po-Makefile.in.in10
2 files changed, 2 insertions, 12 deletions
diff --git a/games/bygfoot/Makefile b/games/bygfoot/Makefile
index f50f42e4cc6f..ba71f6bd39a6 100644
--- a/games/bygfoot/Makefile
+++ b/games/bygfoot/Makefile
@@ -18,10 +18,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
-USES= pkgconfig tar:bzip2
+USES= gettext pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= gtk20
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lm
+LIBS+= -L${LOCALBASE}/lib -lm
.include <bsd.port.mk>
diff --git a/games/bygfoot/files/patch-po-Makefile.in.in b/games/bygfoot/files/patch-po-Makefile.in.in
deleted file mode 100644
index 452490ff9067..000000000000
--- a/games/bygfoot/files/patch-po-Makefile.in.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- po/Makefile.in.in.orig 2008-03-02 17:23:22.000000000 +0100
-+++ po/Makefile.in.in 2008-03-14 14:12:46.000000000 +0100
-@@ -21,6 +21,7 @@
-
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
-+top_builddir = $(top_srcdir)
- VPATH = @srcdir@
-
- prefix = @prefix@