aboutsummaryrefslogtreecommitdiff
path: root/games/chessx
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-06-13 13:01:00 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-06-13 13:01:00 +0000
commit8dc71da9ab3a963f5159fa2232f1ea786aa5ad72 (patch)
treec4ea521507089a0b050fe89e178881859130a7bf /games/chessx
parent8a749f47120d134fabfc829d98c83135c3a823d9 (diff)
downloadports-8dc71da9ab3a963f5159fa2232f1ea786aa5ad72.tar.gz
ports-8dc71da9ab3a963f5159fa2232f1ea786aa5ad72.zip
Add compiler:c++11-lang to USES to fix the following on GCC-based
systems: cc1plus: error: unrecognized command line option "-std=gnu++11"
Notes
Notes: svn path=/head/; revision=504091
Diffstat (limited to 'games/chessx')
-rw-r--r--games/chessx/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/chessx/Makefile b/games/chessx/Makefile
index 657d8b957409..7266e8d8761e 100644
--- a/games/chessx/Makefile
+++ b/games/chessx/Makefile
@@ -12,7 +12,8 @@ COMMENT= Qt 5 chess database application
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= desktop-file-utils qmake:outsource qt:5 shared-mime-info tar:tgz
+USES= compiler:c++11-lang desktop-file-utils qmake:outsource qt:5 \
+ shared-mime-info tar:tgz
USE_QT= buildtools_build concurrent core gui linguisttools_build multimedia \
network opengl printsupport svg widgets xml