aboutsummaryrefslogtreecommitdiff
path: root/games/connectagram/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-02-21 15:16:30 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-02-21 15:16:30 +0000
commit5e4d9d247ba5ae0f3657cb1420926b6a4a432822 (patch)
tree6b248d070a461039b214e155b362acc9cef21571 /games/connectagram/Makefile
parentc773ecf1fbd784f0ae4c29bf135b18d31a575fcf (diff)
downloadports-5e4d9d247ba5ae0f3657cb1420926b6a4a432822.tar.gz
ports-5e4d9d247ba5ae0f3657cb1420926b6a4a432822.zip
Update to 1.2.6
Make translations optional Fix stage-qa warnings Remove INSTALLS_ICONS (Qt apps don't use this) Move USES block upward
Notes
Notes: svn path=/head/; revision=462528
Diffstat (limited to 'games/connectagram/Makefile')
-rw-r--r--games/connectagram/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/games/connectagram/Makefile b/games/connectagram/Makefile
index 43932998f350..922885c1ee6e 100644
--- a/games/connectagram/Makefile
+++ b/games/connectagram/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= connectagram
-PORTVERSION= 1.2.5
+PORTVERSION= 1.2.6
DISTVERSIONSUFFIX= -src
-PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://gottcode.org/connectagram/
@@ -14,20 +13,25 @@ COMMENT= Word unscrambling game
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
USES= compiler:c++11-lib qmake tar:bzip2
+USE_GL= gl
USE_QT5= buildtools_build core gui linguisttools_build network widgets
-INSTALLS_ICONS= yes
-OPTIONS_DEFINE= DOCS
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
post-patch:
@${REINPLACE_CMD} -e \
- 's|share/man|man|;s|metainfo|appdata|' ${WRKSRC}/connectagram.pro
+ 's|share/man|man|' ${WRKSRC}/connectagram.pro
@${REINPLACE_CMD} -e \
's|std::lround|lround|' ${WRKSRC}/src/*.cpp
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e \
+ '/INSTALLS/s|qm||' ${WRKSRC}/connectagram.pro
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} CREDITS ChangeLog NEWS README \