aboutsummaryrefslogtreecommitdiff
path: root/games/conquest
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-06-12 13:15:25 +0000
committerChris Rees <crees@FreeBSD.org>2011-06-12 13:15:25 +0000
commit67deac6bb986d8656c02e0498265d1a849517314 (patch)
treeeda463325dc33aff7d8b5036cfd7aac0dc3c06dd /games/conquest
parent487d52a9bdb0eb30e3c6d638fec13f9d4687c79c (diff)
downloadports-67deac6bb986d8656c02e0498265d1a849517314.tar.gz
ports-67deac6bb986d8656c02e0498265d1a849517314.zip
- Use GROUPS
- Use DATADIR and DOCSDIR - While here, remove obsolete MD5 checksum PR: 157574 Approved by: rene (mentor)
Notes
Notes: svn path=/head/; revision=275438
Diffstat (limited to 'games/conquest')
-rw-r--r--games/conquest/Makefile2
-rw-r--r--games/conquest/distinfo1
-rw-r--r--games/conquest/pkg-install14
-rw-r--r--games/conquest/pkg-plist10
4 files changed, 6 insertions, 21 deletions
diff --git a/games/conquest/Makefile b/games/conquest/Makefile
index c9f29a98eb76..db10495ad67c 100644
--- a/games/conquest/Makefile
+++ b/games/conquest/Makefile
@@ -18,6 +18,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc/conquest \
--datadir=${LOCALBASE}/share/conquest \
--localstatedir=/var/games
+GROUPS= ${PORTNAME}
BINGRP= conquest
SHAREGRP= conquest
MAKE_JOBS_UNSAFE= yes
@@ -29,7 +30,6 @@ post-patch:
${REINPLACE_CMD} "s/-O2 -fPIC//g" ${WRKSRC}/configure
do-install:
- @${SH} pkg-install ${PORTNAME} PRE-INSTALL
${INSTALL_PROGRAM} -m 2550 ${WRKSRC}/conqai ${PREFIX}/sbin
${INSTALL_PROGRAM} -m 2551 ${WRKSRC}/conqdriv ${PREFIX}/libexec
${INSTALL_PROGRAM} -m 2551 ${WRKSRC}/conqoper ${PREFIX}/sbin
diff --git a/games/conquest/distinfo b/games/conquest/distinfo
index 6d10b828695d..dd39bc94cc34 100644
--- a/games/conquest/distinfo
+++ b/games/conquest/distinfo
@@ -1,3 +1,2 @@
-MD5 (conquest-7.2.src.tar.gz) = aeb730dad0e7997701aabee8d6438fce
SHA256 (conquest-7.2.src.tar.gz) = eb18d5e8a0900767bb4319c8b0e34083b13fafb429d2a1c07f86c080d42d831d
SIZE (conquest-7.2.src.tar.gz) = 268979
diff --git a/games/conquest/pkg-install b/games/conquest/pkg-install
index 2df17c83720d..26f77ef404cb 100644
--- a/games/conquest/pkg-install
+++ b/games/conquest/pkg-install
@@ -1,21 +1,7 @@
#!/bin/sh
-[ "${PKG_PREFIX}" ] && PREFIX="${PKG_PREFIX}"
-[ "${PREFIX}" ] || PREFIX=/usr/local
-
case "$2" in
- PRE-INSTALL)
- if ! pw group show conquest >/dev/null 2>&1
- then
- echo "===> Creating group conquest"
- pw add group conquest
- fi
- ;;
POST-INSTALL)
install -d -o root -g conquest -m 770 /var/games/conquest
;;
- *)
- echo "Incorrect parameter"
- exit 1
- ;;
esac
diff --git a/games/conquest/pkg-plist b/games/conquest/pkg-plist
index 3ea2b1d6d5fc..5c41209f9584 100644
--- a/games/conquest/pkg-plist
+++ b/games/conquest/pkg-plist
@@ -4,9 +4,9 @@ libexec/conqdriv
sbin/conqai
sbin/conqoper
sbin/conqstrat
-share/conquest/conqnews.doc.sample
-share/conquest/conquest.doc
-%%PORTDOCS%%share/doc/conquest/README
-%%PORTDOCS%%@dirrm share/doc/conquest
+%%DATADIR%%/conqnews.doc.sample
+%%DATADIR%%/conquest.doc
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm etc/conquest
-@dirrm share/conquest
+@dirrm %%DATADIR%%