aboutsummaryrefslogtreecommitdiff
path: root/games/construo/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 03:39:30 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-25 03:39:30 +0000
commitb6f306f4cc8b973bfa705b0a0d7c567b99fc3f69 (patch)
tree0a167ac2051fe27a3cb514845aa13574613a3402 /games/construo/Makefile
parenta3607c150c3c6fec234bbde4f8e071ed408327db (diff)
downloadports-b6f306f4cc8b973bfa705b0a0d7c567b99fc3f69.tar.gz
ports-b6f306f4cc8b973bfa705b0a0d7c567b99fc3f69.zip
New port: games/construo A fun construction toy
Construo is a simple 2D construction programm (it is currently not a real game) for objects which consist of rods and springs and let them react on physical forces. You can currently construct buildings and objects like bridges, towers, spaceshuttles, etc. and you let them fall to ground and see seem smash and break. Sound like fun, doesn't it =;-) The game is similar to Bridge Builder and heavily inspired from the Gamasutra article Collision Response: Bouncy, Trouncy, Fun. Its covered under the GNU General Public License, thats means source code is availabel and you are allowed to modify it. WWW: http://www.nongnu.org/construo/ PR: ports/89517 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=149372
Diffstat (limited to 'games/construo/Makefile')
-rw-r--r--games/construo/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/games/construo/Makefile b/games/construo/Makefile
new file mode 100644
index 000000000000..b6b8b0289a8e
--- /dev/null
+++ b/games/construo/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: construo
+# Date created: 24 Nov 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= construo
+PORTVERSION= 0.2.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= construo
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A fun construction toy
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_XLIB= yes
+USE_REINPLACE= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+CONFIGURE_ARGS= --bindir=${PREFIX}/bin --datadir=${DATADIR}
+
+OPTIONS= GLUT "Use glut" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GLUT)
+LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+PLIST_SUB+= GLUTBIN:=""
+.else
+PLIST_SUB+= GLUTBIN:="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} 's|bindir = .*|bindir = @bindir@|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} 's|pkgdatadir = .*|pkgdatadir = @datadir@/examples|' ${WRKSRC}/examples/Makefile.in
+ @${REINPLACE_CMD} '/stream/!s/std:://' ${WRKSRC}/vector.cxx
+ @${REINPLACE_CMD} 's|^\(#define CONSTRUO_DATADIR DATADIR\).*|\1|' ${WRKSRC}/construo.hxx
+ @${REINPLACE_CMD} 's|.*glut_1_3_glutMainLoop = yes.*|if false; then|' ${WRKSRC}/configure
+.if defined(WITHOUT_GLUT)
+ @${REINPLACE_CMD} 's|.*glut_glutMainLoop = yes.*|if false; then|' ${WRKSRC}/configure
+.endif
+
+post-install:
+.if defined(WITH_GLUT)
+ cd ${PREFIX}/bin && ${LN} -s ${PORTNAME}.glut ${PORTNAME}
+.else
+ cd ${PREFIX}/bin && ${LN} -s ${PORTNAME}.x11 ${PORTNAME}
+.endif
+
+.include <bsd.port.post.mk>