aboutsummaryrefslogtreecommitdiff
path: root/games/corsix-th/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
commitbeb1c1fe19992999ef068d0dcb07c0d02f4aea71 (patch)
tree464f76d8fe2b9fd7499e26491ee739bfe0a5444e /games/corsix-th/Makefile
parent496124accdd4d4221bb883770cd6fe27184bfc96 (diff)
downloadports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.tar.gz
ports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.zip
USES=lua gained flavors.
Ports using USES=lua:module or lua:flavors will be flavored. A range of supported lua versions can be set using XX-YY (or XX-, or -YY, or simply ZZ) for ports not supporting all lua versions. USES=lua sets LUA_FLAVOR that needs to be used on all dependencies of flavored lua ports, in a similar way as PHP or Python flavors. PR: 245038 Submitted by: andrew tao11 riddles org uk Reviewed by: mat, kevans, russ haley gmail com Approved by: mat (portmgr) Differential Revision: https://reviews.freebsd.org/D16494
Notes
Notes: svn path=/head/; revision=531700
Diffstat (limited to 'games/corsix-th/Makefile')
-rw-r--r--games/corsix-th/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index 062c1536379e..9db04297dfec 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -13,8 +13,8 @@ COMMENT= Open source clone of Theme Hospital
LICENSE= MIT
LIB_DEPENDS= libfreetype.so:print/freetype2
-RUN_DEPENDS= ${LUA_MODLIBDIR}/lfs.so:devel/luafilesystem \
- ${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg
+RUN_DEPENDS= ${LUA_REFMODLIBDIR}/lfs.so:devel/luafilesystem@${LUA_FLAVOR} \
+ ${LUA_REFMODLIBDIR}/lpeg.so:devel/lua-lpeg@${LUA_FLAVOR}
USES= cmake:insource compiler:c++11-lib desktop-file-utils dos2unix \
iconv lua pkgconfig sdl