aboutsummaryrefslogtreecommitdiff
path: root/games/corsix-th/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-11-24 17:24:37 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-11-24 17:24:37 +0000
commitbeffdf5c6f442f4c432ae3f979a74a73661b9454 (patch)
treee2b68a5648b1e6a215ca3d07859c8810a9409ae8 /games/corsix-th/Makefile
parentd441d95202277ac250376c150022787a0c147b63 (diff)
downloadports-beffdf5c6f442f4c432ae3f979a74a73661b9454.tar.gz
ports-beffdf5c6f442f4c432ae3f979a74a73661b9454.zip
Welcome CorsixTH, an open source clone of Theme Hospital.
Notes
Notes: svn path=/head/; revision=265096
Diffstat (limited to 'games/corsix-th/Makefile')
-rw-r--r--games/corsix-th/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
new file mode 100644
index 000000000000..6f76eb04567f
--- /dev/null
+++ b/games/corsix-th/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: CorsixTH
+# Date created: 24 Nov 2010
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= corsixth
+DISTVERSION= 0.Beta4
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PROJECTHOST= corsix-th
+DISTNAME= CorsixTH-${DISTVERSION:S/0.//}-Source
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Open source clone of Theme Hospital
+
+RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
+
+USE_CMAKE= yes
+USE_LUA= yes
+USE_SDL= mixer
+
+post-patch:
+# Allow the game to find its resources without wrapper scripts
+ @${REINPLACE_CMD} -e \
+ '/return loadfile/s,name,\\"${DATADIR}/\\" .. &,' \
+ ${WRKSRC}/CorsixTH/Src/main.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/CorsixTH/CorsixTH ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/CorsixTH/CorsixTH.lua ${DATADIR}
+ cd ${WRKSRC}/CorsixTH && ${COPYTREE_SHARE} "Bitmap Levels Lua" \
+ ${DATADIR}
+
+.include <bsd.port.mk>