aboutsummaryrefslogtreecommitdiff
path: root/games/crispy-doom
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-05-02 16:15:20 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-05-02 16:15:20 +0000
commitc85d60dcbeb373cd63f0993c003dbad9f06b6f2f (patch)
tree687b44df162f1ef6f9e71015bf3e929d9c65c53c /games/crispy-doom
parent0c7365183893cdf9c5932db56ff84aab72ea271b (diff)
downloadports-c85d60dcbeb373cd63f0993c003dbad9f06b6f2f.tar.gz
ports-c85d60dcbeb373cd63f0993c003dbad9f06b6f2f.zip
New port: games/crispy-doom
Crispy Doom is a friendly fork of Chocolate Doom that provides a higher display resolution, removes the static limits of the Doom engine and offers further optional visual, tactical and physical enhancements while remaining entirely config file, savegame, netplay and demo compatible with the original.
Notes
Notes: svn path=/head/; revision=533694
Diffstat (limited to 'games/crispy-doom')
-rw-r--r--games/crispy-doom/Makefile29
-rw-r--r--games/crispy-doom/distinfo3
-rw-r--r--games/crispy-doom/files/patch-src_Makefile.am50
-rw-r--r--games/crispy-doom/pkg-descr6
-rw-r--r--games/crispy-doom/pkg-plist28
5 files changed, 116 insertions, 0 deletions
diff --git a/games/crispy-doom/Makefile b/games/crispy-doom/Makefile
new file mode 100644
index 000000000000..b9ec6d0e3c03
--- /dev/null
+++ b/games/crispy-doom/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= crispy-doom
+PORTVERSION= 5.8.0
+CATEGORIES= games
+
+MAINTAINER= danilo@FreeBSD.org
+COMMENT= Enhanced-resolution Doom source port based on Chocolate Doom
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
+ libpng16.so:graphics/png
+
+USES= autoreconf pkgconfig sdl
+
+USE_SDL= mixer2 net2 sdl2
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= DOCS
+
+USE_GITHUB= yes
+GH_ACCOUNT= fabiangreffrath
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/crispy-*
+
+.include <bsd.port.mk>
diff --git a/games/crispy-doom/distinfo b/games/crispy-doom/distinfo
new file mode 100644
index 000000000000..9ba215d5b712
--- /dev/null
+++ b/games/crispy-doom/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588371686
+SHA256 (fabiangreffrath-crispy-doom-5.8.0-crispy-doom-5.8.0_GH0.tar.gz) = c485de2c2920b50434f468795ce4025cf6d2c12f3cfcf484464544566b8fa290
+SIZE (fabiangreffrath-crispy-doom-5.8.0-crispy-doom-5.8.0_GH0.tar.gz) = 2627570
diff --git a/games/crispy-doom/files/patch-src_Makefile.am b/games/crispy-doom/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..2d0eb4cf0355
--- /dev/null
+++ b/games/crispy-doom/files/patch-src_Makefile.am
@@ -0,0 +1,50 @@
+--- src/Makefile.am.orig 2020-05-02 15:07:41 UTC
++++ src/Makefile.am
+@@ -5,16 +5,16 @@ execgamesdir = ${bindir}
+
+ execgames_PROGRAMS = @PROGRAM_PREFIX@doom \
+ @PROGRAM_PREFIX@heretic \
+- @PROGRAM_PREFIX@server
+-EXTRA_PROGRAMS = @PROGRAM_PREFIX@hexen \
++ @PROGRAM_PREFIX@server \
++ @PROGRAM_PREFIX@hexen \
+ @PROGRAM_PREFIX@strife
+
+ noinst_PROGRAMS = @PROGRAM_PREFIX@setup
+
+ SETUP_BINARIES = @PROGRAM_PREFIX@doom-setup$(EXEEXT) \
+- @PROGRAM_PREFIX@heretic-setup$(EXEEXT)
+-# @PROGRAM_PREFIX@hexen-setup$(EXEEXT) \
+-# @PROGRAM_PREFIX@strife-setup$(EXEEXT)
++ @PROGRAM_PREFIX@heretic-setup$(EXEEXT) \
++ @PROGRAM_PREFIX@hexen-setup$(EXEEXT) \
++ @PROGRAM_PREFIX@strife-setup$(EXEEXT)
+
+ execgames_SCRIPTS = $(SETUP_BINARIES)
+
+@@ -225,9 +225,9 @@ EXTRA_DIST = \
+ metainfodir = $(prefix)/share/metainfo
+ metainfo_DATA = \
+ @PACKAGE_RDNS@.Doom.metainfo.xml \
+- @PACKAGE_RDNS@.Heretic.metainfo.xml
+-# @PACKAGE_RDNS@.Hexen.metainfo.xml \
+-# @PACKAGE_RDNS@.Strife.metainfo.xml
++ @PACKAGE_RDNS@.Heretic.metainfo.xml \
++ @PACKAGE_RDNS@.Hexen.metainfo.xml \
++ @PACKAGE_RDNS@.Strife.metainfo.xml
+
+ @PACKAGE_RDNS@.Doom.metainfo.xml : Doom.metainfo.xml
+ cp Doom.metainfo.xml $@
+@@ -244,9 +244,9 @@ metainfo_DATA = \
+ appdir = $(prefix)/share/applications
+ app_DATA = \
+ @PACKAGE_RDNS@.Doom.desktop \
+- @PACKAGE_RDNS@.Heretic.desktop
+-# @PACKAGE_RDNS@.Hexen.desktop \
+-# @PACKAGE_RDNS@.Strife.desktop
++ @PACKAGE_RDNS@.Heretic.desktop \
++ @PACKAGE_RDNS@.Hexen.desktop \
++ @PACKAGE_RDNS@.Strife.desktop
+
+ @PACKAGE_RDNS@.Doom.desktop : Doom.desktop
+ cp Doom.desktop $@
diff --git a/games/crispy-doom/pkg-descr b/games/crispy-doom/pkg-descr
new file mode 100644
index 000000000000..1e023ab3ae1d
--- /dev/null
+++ b/games/crispy-doom/pkg-descr
@@ -0,0 +1,6 @@
+Crispy Doom is a friendly fork of Chocolate Doom that provides a higher
+display resolution, removes the static limits of the Doom engine and offers
+further optional visual, tactical and physical enhancements while remaining
+entirely config file, savegame, netplay and demo compatible with the original.
+
+WWW: https://github.com/fabiangreffrath/crispy-doom
diff --git a/games/crispy-doom/pkg-plist b/games/crispy-doom/pkg-plist
new file mode 100644
index 000000000000..956a0b943eda
--- /dev/null
+++ b/games/crispy-doom/pkg-plist
@@ -0,0 +1,28 @@
+bin/crispy-doom
+bin/crispy-doom-setup
+bin/crispy-heretic
+bin/crispy-heretic-setup
+bin/crispy-hexen
+bin/crispy-hexen-setup
+bin/crispy-server
+bin/crispy-strife
+bin/crispy-strife-setup
+share/applications/io.github.fabiangreffrath.Doom.desktop
+share/applications/io.github.fabiangreffrath.Heretic.desktop
+share/applications/io.github.fabiangreffrath.Hexen.desktop
+share/applications/io.github.fabiangreffrath.Setup.desktop
+share/applications/io.github.fabiangreffrath.Strife.desktop
+share/applications/screensavers/io.github.fabiangreffrath.Doom_Screensaver.desktop
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.md
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS.md
+%%PORTDOCS%%%%DOCSDIR%%/NOT-BUGS.md
+%%PORTDOCS%%%%DOCSDIR%%/PHILOSOPHY.md
+%%PORTDOCS%%%%DOCSDIR%%/README.Music.md
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+share/icons/hicolor/128x128/apps/crispy-doom.png
+share/icons/hicolor/128x128/apps/crispy-setup.png
+share/metainfo/io.github.fabiangreffrath.Doom.metainfo.xml
+share/metainfo/io.github.fabiangreffrath.Heretic.metainfo.xml
+share/metainfo/io.github.fabiangreffrath.Hexen.metainfo.xml
+share/metainfo/io.github.fabiangreffrath.Strife.metainfo.xml