aboutsummaryrefslogtreecommitdiff
path: root/games/crossfire-server/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-07-10 17:50:25 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-07-10 17:50:25 +0000
commitbd70375e9a0661fa28d8ae90a9f5d1c01d14eee9 (patch)
treef5b6e9950995669372bd8fc024358b6daaa0c97c /games/crossfire-server/Makefile
parent3e71b2e1a172e8c8d06ae82671b2586b4ef1fb00 (diff)
downloadports-bd70375e9a0661fa28d8ae90a9f5d1c01d14eee9.tar.gz
ports-bd70375e9a0661fa28d8ae90a9f5d1c01d14eee9.zip
Update to to 1.9.1
PR: 100033 Submitted by: Ports fury
Notes
Notes: svn path=/head/; revision=167370
Diffstat (limited to 'games/crossfire-server/Makefile')
-rw-r--r--games/crossfire-server/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index 8b650d3ec1d8..b015b54d9aad 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -6,32 +6,44 @@
#
PORTNAME= crossfire
-PORTVERSION= 1.9.0
+PORTVERSION= 1.9.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.real-time.com/pub/games/crossfire/
-MASTER_SITE_SUBDIR= crossfire
+MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -server
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${DISTNAME}-1.maps${EXTRACT_SUFX}
+ ${DISTNAME}.maps${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Server for multiplayer graphical arcade and adventure game
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_XPM= yes
USE_PERL5= yes
+USE_PYTHON= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --without-check
MAN6= crossedit.6 crossfire.6 crossfire-config.6 crossloop.6 \
crossloop.web.6
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include \
+ -I${PYTHON_INCLUDEDIR} ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib \
+ -L${PYTHON_LIBDIR} ${PTHREAD_LIBS}
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-ldl||g'
+ @${REINPLACE_CMD} -e 's|^#.*/bin/sh|#! ${LOCALBASE}/bin/bash|g ; \
+ s|python[{].*[}]|${PYTHON_VERSION}|g ; \
+ s|-ldl||g' ${WRKSRC}/configure
post-install:
@${MKDIR} ${DATADIR}/maps