aboutsummaryrefslogtreecommitdiff
path: root/games/cube/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-02-20 06:53:37 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-02-20 06:53:37 +0000
commit6047e60d752345fe4b73b22da27be4656e6d09df (patch)
treea10f654d060210d22acc8cbd368563ab82fab1b6 /games/cube/Makefile
parent00b407013b8400c492267901653fa659d6a5fe18 (diff)
downloadports-6047e60d752345fe4b73b22da27be4656e6d09df.tar.gz
ports-6047e60d752345fe4b73b22da27be4656e6d09df.zip
- Fix invalid dereferencing of null reference which causes startup
crash for cube_client when built with clang 3.6 + -O1 or higher [1] - Properly track libenet dependency [2] PR: 197604 [1] PR: 197605 [2] Submitted by: dim [1]
Notes
Notes: svn path=/head/; revision=379412
Diffstat (limited to 'games/cube/Makefile')
-rw-r--r--games/cube/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/cube/Makefile b/games/cube/Makefile
index 637d2129978a..ec789a474b16 100644
--- a/games/cube/Makefile
+++ b/games/cube/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cube
DISTVERSION= 2005_08_29
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
DISTFILES= ${CUBE_DATA} ${CUBE_SRC}
@@ -11,9 +11,10 @@ DISTFILES= ${CUBE_DATA} ${CUBE_SRC}
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL 3D FPS (first person shooter) game
-BUILD_DEPENDS= ${LOCALBASE}/lib/libenet.a:${PORTSDIR}/net/enet
+LIB_DEPENDS= libenet.so:${PORTSDIR}/net/enet
USES= dos2unix gmake
+EXTRACT_AFTER_ARGS=--exclude enet
ALL_TARGET= #
USE_XORG= x11