aboutsummaryrefslogtreecommitdiff
path: root/games/cuyo/Makefile
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2009-06-06 22:49:23 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2009-06-06 22:49:23 +0000
commitea8763c056e09d7fa40db574078e5bfb79afbe3d (patch)
tree31512d441b090dcd305d481c1de91773874fb836 /games/cuyo/Makefile
parent9c5972786d0fd9e3b5b2f806972728c61411380a (diff)
downloadports-ea8763c056e09d7fa40db574078e5bfb79afbe3d.tar.gz
ports-ea8763c056e09d7fa40db574078e5bfb79afbe3d.zip
Cuyo is a tetris-like game which is suprisingly innovative,
sometimes challenging, and has a very nice look. WWW: http://www.karimmi.de/cuyo/ PR: ports/135166 Submitted by: Matthew Gibson <mdg583 at hotmail.com> Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=235340
Diffstat (limited to 'games/cuyo/Makefile')
-rw-r--r--games/cuyo/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/cuyo/Makefile b/games/cuyo/Makefile
new file mode 100644
index 000000000000..ce676ea0ca1b
--- /dev/null
+++ b/games/cuyo/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: cuyo
+# Date created: 1 June 2009
+# Whom: Matthew Gibson <mdg583@hotmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cuyo
+PORTVERSION= 2.1.1
+CATEGORIES= games
+MASTER_SITES= http://mirror.publicns.net/pub/nongnu/cuyo/
+DISTNAME= ${PORTNAME}-2.~-1.1
+
+MAINTAINER= mdg583@hotmail.com
+COMMENT= A nice, innovative, challenging tetris-like game
+
+LIB_DEPENDS= aa.1:${PORTSDIR}/graphics/aalib mikmod.2:${PORTSDIR}/audio/libmikmod
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= mixer image
+USE_XORG= xdmcp xau x11
+USE_ICONV= yes
+INSTALLS_ICONS= yes
+
+MAN6= cuyo.6 cual.6
+
+post-install:
+ @${ECHO} Installing ${PREFIX}/share/pixmaps/cuyo.png
+ @${INSTALL_DATA} ${WRKSRC}/icons/cuyo-32x32.png ${PREFIX}/share/pixmaps/cuyo.png
+
+.include <bsd.port.mk>