aboutsummaryrefslogtreecommitdiff
path: root/games/dangerdeep-data
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-11-01 04:11:52 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-11-01 04:11:52 +0000
commit4097eac6ec5752f0185e090b706ee8e99641e530 (patch)
tree9f5f5676ba70b80c5b0bae0d0a719a21b0740581 /games/dangerdeep-data
parenteff49a089b4021d776005ccf0433bd30c624bb40 (diff)
downloadports-4097eac6ec5752f0185e090b706ee8e99641e530.tar.gz
ports-4097eac6ec5752f0185e090b706ee8e99641e530.zip
- New port: games/dangerdeep-data
The Danger From the Deep data files WWW: http://www.dangerdeep.net
Notes
Notes: svn path=/head/; revision=175986
Diffstat (limited to 'games/dangerdeep-data')
-rw-r--r--games/dangerdeep-data/Makefile40
-rw-r--r--games/dangerdeep-data/distinfo3
-rw-r--r--games/dangerdeep-data/pkg-descr3
3 files changed, 46 insertions, 0 deletions
diff --git a/games/dangerdeep-data/Makefile b/games/dangerdeep-data/Makefile
new file mode 100644
index 000000000000..58a33e8a1b81
--- /dev/null
+++ b/games/dangerdeep-data/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: dangerdeep-data
+# Date created: 2006-10-12
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= data
+PORTVERSION= 0.2.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dangerdeep
+PKGNAMEPREFIX= dangerdeep-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= The Danger from the Deep data files
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+DATADIR= share/${PKGNAMEPREFIX:S/-//}
+PLIST= ${WRKDIR}/pkg-plist
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKSRC} && \
+ ${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+ @${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${DATADIR}
+ cd ${WRKSRC} && \
+ ${FIND} * -type d -exec ${MKDIR} "${PREFIX}/${DATADIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${PREFIX}/${DATADIR}/{}" \;
+
+.include <bsd.port.mk>
diff --git a/games/dangerdeep-data/distinfo b/games/dangerdeep-data/distinfo
new file mode 100644
index 000000000000..4008ed44b66e
--- /dev/null
+++ b/games/dangerdeep-data/distinfo
@@ -0,0 +1,3 @@
+MD5 (dangerdeep/dangerdeep-data-0.2.0.zip) = 931d035cdf07d29b57e4797218fe53ff
+SHA256 (dangerdeep/dangerdeep-data-0.2.0.zip) = 7b96f41e38a2478b3c5b40bd5e81a45437902f370718676c6077c2edcd5c5e10
+SIZE (dangerdeep/dangerdeep-data-0.2.0.zip) = 54163740
diff --git a/games/dangerdeep-data/pkg-descr b/games/dangerdeep-data/pkg-descr
new file mode 100644
index 000000000000..a488f4d7abf0
--- /dev/null
+++ b/games/dangerdeep-data/pkg-descr
@@ -0,0 +1,3 @@
+The Danger From the Deep data files
+
+WWW: http://www.dangerdeep.net