aboutsummaryrefslogtreecommitdiff
path: root/games/defendguin/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /games/defendguin/Makefile
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'games/defendguin/Makefile')
-rw-r--r--games/defendguin/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/defendguin/Makefile b/games/defendguin/Makefile
index 507267c1dc80..16903d3181d2 100644
--- a/games/defendguin/Makefile
+++ b/games/defendguin/Makefile
@@ -30,7 +30,7 @@ DESKTOP_ENTRIES="Defendguin" "" "${PORTNAME}" \
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -DDATA_PREFIX=\"${DATADIR}/\" \
`${SDL_CONFIG} --cflags` defendguin.c -o defendguin \
- `${SDL_CONFIG} --libs` -lSDL_mixer
+ `${SDL_CONFIG} --libs` -lSDL_mixer -lm
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/