aboutsummaryrefslogtreecommitdiff
path: root/games/diameter
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-09-29 12:59:39 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-09-29 12:59:39 +0000
commita48cd38989dc995ed2aa5516d910c93c261df4be (patch)
tree4f968b2c686f76b8ae3d100d2bebd199a0816be3 /games/diameter
parentf5302bfb2ced9f65f4dd4b2e4ebfd45a32e3d148 (diff)
downloadports-a48cd38989dc995ed2aa5516d910c93c261df4be.tar.gz
ports-a48cd38989dc995ed2aa5516d910c93c261df4be.zip
- Chase devel/guichan 0.5.0 update
PR: ports/103686 Submitted by: Dmitry Marakasov <amdmi3 at mail.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=174107
Diffstat (limited to 'games/diameter')
-rw-r--r--games/diameter/Makefile4
-rw-r--r--games/diameter/files/patch-src-gra-2d-gui.cpp25
-rw-r--r--games/diameter/files/patch-src-gra-2d-gui.h19
3 files changed, 47 insertions, 1 deletions
diff --git a/games/diameter/Makefile b/games/diameter/Makefile
index fd3255910ba0..6ff779cb58d8 100644
--- a/games/diameter/Makefile
+++ b/games/diameter/Makefile
@@ -7,6 +7,7 @@
PORTNAME= diameter
DISTVERSION= 0.3.5-r1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gamediameter
@@ -15,7 +16,8 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}src
MAINTAINER= amdmi3@mail.ru
COMMENT= Arcade-style game with elements of economy and adventure
-LIB_DEPENDS= guichan.0:${PORTSDIR}/devel/guichan
+BUILD_DEPENDS= guichan>=0.5.0:${PORTSDIR}/devel/guichan
+RUN_DEPENDS= guichan>=0.5.0:${PORTSDIR}/devel/guichan
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/games/diameter/files/patch-src-gra-2d-gui.cpp b/games/diameter/files/patch-src-gra-2d-gui.cpp
new file mode 100644
index 000000000000..63aac918974b
--- /dev/null
+++ b/games/diameter/files/patch-src-gra-2d-gui.cpp
@@ -0,0 +1,25 @@
+--- src/gra/2d/gui.cpp.orig Sat Jun 24 02:16:12 2006
++++ src/gra/2d/gui.cpp Tue Sep 26 21:23:20 2006
+@@ -3,11 +3,11 @@
+ void DGUI::Init(Options in_option)
+ {
+ option=in_option;
+-imageLoader = new gcn::OpenGLImageLoader();
++imageLoader = new gcn::OpenGLSDLImageLoader();
+ hostImageLoader = new gcn::SDLImageLoader();
+ // The OpenGL imageloader cant load images by itself, it needs
+ // a host imageloader. So we give it an SDL imageloader.
+-imageLoader->setHostImageLoader(hostImageLoader);
++//imageLoader->setHostImageLoader(hostImageLoader);
+ gcn::Image::setImageLoader(imageLoader);
+ graphics = new gcn::OpenGLGraphics();
+ // We need to tell OpenGL graphics how big the screen is.
+@@ -83,7 +83,7 @@
+ b_ExitGame->setPosition(top->getWidth()/2-b_ExitGame->getWidth()/2, top->getHeight()/2+100);
+
+ std::string temp_string = "texture/gui/logo.png";
+-TempImage1 = new gcn::Image(PKGDATADIR+temp_string);
++TempImage1 = gcn::Image::load(PKGDATADIR+temp_string);
+ diameter_icon = new gcn::Icon(TempImage1);
+ diameter_icon->setPosition(top->getWidth()/2-diameter_icon->getWidth()/2, top->getHeight()/2-150);
+
diff --git a/games/diameter/files/patch-src-gra-2d-gui.h b/games/diameter/files/patch-src-gra-2d-gui.h
new file mode 100644
index 000000000000..c765c06b263f
--- /dev/null
+++ b/games/diameter/files/patch-src-gra-2d-gui.h
@@ -0,0 +1,19 @@
+--- src/gra/2d/gui.h.orig Thu Jun 22 17:11:02 2006
++++ src/gra/2d/gui.h Tue Sep 26 21:23:20 2006
+@@ -4,6 +4,7 @@
+ #include <guichan.hpp>
+ #include <guichan/sdl.hpp>
+ #include <guichan/opengl.hpp>
++#include <guichan/opengl/openglsdlimageloader.hpp>
+ #include <GL/gl.h>
+ #include <sstream>
+
+@@ -17,7 +18,7 @@
+ {
+ gcn::SDLInput* input;
+ gcn::OpenGLGraphics* graphics;
+-gcn::OpenGLImageLoader* imageLoader;
++gcn::OpenGLSDLImageLoader* imageLoader;
+ gcn::SDLImageLoader* hostImageLoader;
+
+ /*