aboutsummaryrefslogtreecommitdiff
path: root/games/diameter
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-20 20:09:25 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-20 20:09:25 +0000
commitb0154d024ca11386aaf9723756e3bebd1a994c95 (patch)
tree5b2156a7a0f7a4a6d0b734efcfc884cc59d1c0f6 /games/diameter
parent03624cd1bfa01864ce009f1cb9c011cbf85469af (diff)
downloadports-b0154d024ca11386aaf9723756e3bebd1a994c95.tar.gz
ports-b0154d024ca11386aaf9723756e3bebd1a994c95.zip
games/diameter: fix build on GCC architectures
C++11 compiler is required: res/3dsloader.cpp:77: error: 'nullptr' was not declared in this scope Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=507021
Diffstat (limited to 'games/diameter')
-rw-r--r--games/diameter/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/diameter/Makefile b/games/diameter/Makefile
index 9a8feca52e36..9b090a2e9d11 100644
--- a/games/diameter/Makefile
+++ b/games/diameter/Makefile
@@ -16,7 +16,7 @@ BROKEN_armv7= fails to compile: res/3dsloader.cpp:77:15: comparison between poi
LIB_DEPENDS= libpng.so:graphics/png \
libguichan.so:devel/guichan
-USES= dos2unix tar:bzip2 gmake pkgconfig python:2.7
+USES= compiler:c++11-lang dos2unix tar:bzip2 gmake pkgconfig python:2.7
DOS2UNIX_FILES= src/res/3dsloader.cpp
GNU_CONFIGURE= yes
USE_GL= gl glu