aboutsummaryrefslogtreecommitdiff
path: root/games/divide-and-succeed/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-22 16:50:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-22 16:50:42 +0000
commit27f04138cdb5d11550df4a40bc6e7d2e8e1f0a46 (patch)
treefaa0bc43d9ae7a2eac34191598cb2813f57c2483 /games/divide-and-succeed/Makefile
parent3e6732d9a2fb6dc342c35cf1d6e72667dc6e004b (diff)
downloadports-27f04138cdb5d11550df4a40bc6e7d2e8e1f0a46.tar.gz
ports-27f04138cdb5d11550df4a40bc6e7d2e8e1f0a46.zip
Divide and succeed is a slicing cake game :-D
You have to cut a Polygon in a specific number of equal parts using a specific number of lines. Levels consists of a list of Polygons, a number of parts and a number of slices. Maximum width allowed for a level is 600, Maximum height is 400. There is no level editor at the moment, so it's text-editor style. WWW: http://projects.haxx.es/p/divide-and-succeed/
Notes
Notes: svn path=/head/; revision=434597
Diffstat (limited to 'games/divide-and-succeed/Makefile')
-rw-r--r--games/divide-and-succeed/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/games/divide-and-succeed/Makefile b/games/divide-and-succeed/Makefile
new file mode 100644
index 000000000000..52fc1a150aa5
--- /dev/null
+++ b/games/divide-and-succeed/Makefile
@@ -0,0 +1,23 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= divide-and-succeed
+PORTVERSION= 0.9.4
+CATEGORIES= games
+MASTER_SITES= http://projects.haxx.es/media/upload/${PORTNAME}/files/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Divide polygons into the rigth number of equal parts
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake
+USE_SDL= sdl ttf
+DATADIR= ${PREFIX}/share/divideandsucceed
+INSTALLS_ICONS= yes
+
+post-install:
+ ${LN} -s ../../share/icons/hicolor/64x64/apps/divideandsucceed.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>