aboutsummaryrefslogtreecommitdiff
path: root/games/dodgindiamond2/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-17 15:53:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-17 15:53:26 +0000
commit0c320fdf247d49950874a36b5d871d190ce99e6d (patch)
tree5ca8845e60ff0df58d6e2f26b7f87a0fe9f8307d /games/dodgindiamond2/files
parent618d6d03836cac5c720832fee782c6228a3304fb (diff)
downloadports-0c320fdf247d49950874a36b5d871d190ce99e6d.tar.gz
ports-0c320fdf247d49950874a36b5d871d190ce99e6d.zip
Add Dodging Diamond 2, an old school shoot-em up game.
PR: ports/69102 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
Notes
Notes: svn path=/head/; revision=113838
Diffstat (limited to 'games/dodgindiamond2/files')
-rw-r--r--games/dodgindiamond2/files/patch-src::Makefile.in11
-rw-r--r--games/dodgindiamond2/files/patch-src::data::Makefile.in19
-rw-r--r--games/dodgindiamond2/files/patch-src::main.c29
3 files changed, 59 insertions, 0 deletions
diff --git a/games/dodgindiamond2/files/patch-src::Makefile.in b/games/dodgindiamond2/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..f0b924eeede9
--- /dev/null
+++ b/games/dodgindiamond2/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Thu Jul 15 15:23:01 2004
++++ src/Makefile.in Thu Jul 15 15:23:41 2004
+@@ -73,7 +73,7 @@
+ dd2_SOURCES = menu.c SDL_plus.c cfg.c engine.c control.c engine.h control.h cfg.h SDL_plus.h menu.h main.c main.h
+ EXTRA_DIST = menu.c SDL_plus.c cfg.c engine.c control.c engine.h control.h cfg.h SDL_plus.h menu.h main.c main.h
+
+-AM_CFLAGS = -DDD2_DATA=\"$(pkgdatadir)\" -Wall
++AM_CFLAGS = -DDD2_DATA=\"$(pkgdatadir)\" -DSYSCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -Wall
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_CLEAN_FILES =
+ PROGRAMS = $(bin_PROGRAMS)
diff --git a/games/dodgindiamond2/files/patch-src::data::Makefile.in b/games/dodgindiamond2/files/patch-src::data::Makefile.in
new file mode 100644
index 000000000000..54a315bc23ec
--- /dev/null
+++ b/games/dodgindiamond2/files/patch-src::data::Makefile.in
@@ -0,0 +1,19 @@
+--- src/data/Makefile.in.orig Fri Jul 2 17:43:12 2004
++++ src/data/Makefile.in Thu Jul 15 15:28:35 2004
+@@ -65,7 +65,7 @@
+ SDL_LIBS = @SDL_LIBS@
+ VERSION = @VERSION@
+
+-pkgdata_DATA = bgm1.xm bgm2.xm efx1.wav efx2.wav efx3.wav efx4.wav efx5.wav efx6.wav efx7.wav efx8.wav gfx.bmp dd2.cfg game.act dd2-hiscore
++pkgdata_DATA = bgm1.xm bgm2.xm efx1.wav efx2.wav efx3.wav efx4.wav efx5.wav efx6.wav efx7.wav efx8.wav gfx.bmp game.act
+
+ EXTRA_DIST = bgm1.xm bgm2.xm efx1.wav efx2.wav efx3.wav efx4.wav efx5.wav efx6.wav efx7.wav efx8.wav gfx.bmp dd2.cfg game.act dd2-hiscore
+
+@@ -192,7 +192,6 @@
+
+
+ install-data-hook:
+- chmod a+rw $(pkgdatadir)/dd2-hiscore
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/games/dodgindiamond2/files/patch-src::main.c b/games/dodgindiamond2/files/patch-src::main.c
new file mode 100644
index 000000000000..ad1f4590b3a8
--- /dev/null
+++ b/games/dodgindiamond2/files/patch-src::main.c
@@ -0,0 +1,29 @@
+--- src/main.c.orig Thu Jul 15 15:04:36 2004
++++ src/main.c Thu Jul 15 15:17:57 2004
+@@ -284,7 +284,7 @@
+ sprintf(buffer,"%.500s/.dd2rc",getenv("HOME"));
+ if(!loadCFG(buffer,&conf)) {
+ /* if there's no local, use global */
+- sprintf(buffer,"%s/dd2.cfg",DD2_DATA);
++ sprintf(buffer,"%s/dd2.cfg",SYSCONFDIR);
+ if(!loadCFG(buffer,&conf))
+ fprintf(stderr,"unable to read configuration, using defaults\n");
+ }
+@@ -295,7 +295,7 @@
+ #endif
+
+ /* read hi-scores */
+- sprintf(buffer,"%s/dd2-hiscore",DD2_DATA);
++ sprintf(buffer,"%s/dd2-hiscore",LOCALSTATEDIR);
+ if(!loadScore(buffer,hiscore))
+ fprintf(stderr,"unable to read hi-scores, using defaults\n");
+
+@@ -462,7 +462,7 @@
+ saveCFG(buffer,&conf);
+
+ /* save hi-scores */
+- sprintf(buffer,"%s/dd2-hiscore",DD2_DATA);
++ sprintf(buffer,"%s/dd2-hiscore",LOCALSTATEDIR);
+ if(!saveScore(buffer,hiscore))
+ fprintf(stderr,"unable to save hi-scores\ndo you have permissions to write into %s?\n"
+ ,buffer);