aboutsummaryrefslogtreecommitdiff
path: root/games/doom-data
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-11-17 11:28:34 +0000
committerSimon Barner <barner@FreeBSD.org>2005-11-17 11:28:34 +0000
commit428fe6f85fd26ea306c3fae697d7770d7c395ffe (patch)
treeec61349ff5119c80e84d5799a839f8c1a6b25122 /games/doom-data
parentcb84d24c50fd77124ccc9ffe12c27498f907b15a (diff)
downloadports-428fe6f85fd26ea306c3fae697d7770d7c395ffe.tar.gz
ports-428fe6f85fd26ea306c3fae697d7770d7c395ffe.zip
Add doom-data 1.0.
Doom data files (the shareware versions of Doom, Doom II, Hexen, Heretic and Strife). This port is the basis of a new framework that allows DooM ports to share their data files. The cannoical location of those WAD files is ${LOCALBASE}/share/doom (the directory is owned by this port). In order to create your own port for a DooM WAD port, please see games/doom-hr for an example. PR: 86439 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Notes
Notes: svn path=/head/; revision=148574
Diffstat (limited to 'games/doom-data')
-rw-r--r--games/doom-data/Makefile75
-rw-r--r--games/doom-data/Makefile.include42
-rw-r--r--games/doom-data/distinfo12
-rw-r--r--games/doom-data/files/pkg-message.in9
-rw-r--r--games/doom-data/pkg-descr6
-rw-r--r--games/doom-data/pkg-plist5
6 files changed, 149 insertions, 0 deletions
diff --git a/games/doom-data/Makefile b/games/doom-data/Makefile
new file mode 100644
index 000000000000..406bcc5032cc
--- /dev/null
+++ b/games/doom-data/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: doom-data
+# Date created: 21 Sep 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= data
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.ijs.si/~lesi/distfiles/doom/
+EXTRACT_SUFX= .bz2
+DISTFILES= #
+DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Doom data files (Doom, Doom II, Hexen, Heretic and Strife)
+
+USE_BZIP2= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+OPTIONS= DOOM "Install Doom shareware data" on \
+ HERETIC "Install Heretic shareware data" off \
+ HEXEN "Install Hexen shareware data" off \
+ STRIFE "Install Strife shareware data" off
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
+
+LIST= DOOM HERETIC HEXEN STRIFE
+
+DOOM_WAD= doom1.wad
+HERETIC_WAD= heretic1.wad
+HEXEN_WAD= hexen.wad
+STRIFE_WAD= strife0.wad
+
+.include "Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+.for f in ${LIST}
+. if defined(WITH_${f})
+DISTFILES+= ${${f}_WAD}${EXTRACT_SUFX}
+PLIST_SUB+= ${f}=""
+. else
+PLIST_SUB+= ${f}="@comment "
+. endif
+.endfor
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+.for f in ${LIST}
+. if defined(WITH_${f})
+ @${BZIP2_CMD} -dc ${_DISTDIR}/${${f}_WAD}${EXTRACT_SUFX} > \
+ ${WRKDIR}/${${f}_WAD}
+. endif
+.endfor
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in ${LIST}
+. if defined(WITH_${f})
+ @${INSTALL_DATA} ${WRKSRC}/${${f}_WAD} ${DATADIR}
+. endif
+.endfor
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.post.mk>
diff --git a/games/doom-data/Makefile.include b/games/doom-data/Makefile.include
new file mode 100644
index 000000000000..56fbf31b7dcc
--- /dev/null
+++ b/games/doom-data/Makefile.include
@@ -0,0 +1,42 @@
+# Makefile for defining variables used by other Doom related ports.
+
+# Determine if the port is a Doom engine.
+
+DMENGINES= deng doom doomlegacy prboom vavoom
+
+.for f in ${DMENGINES}
+. if ${PORTNAME} == ${f}
+ENGINE= yes
+. endif
+.endfor
+
+# Package name prefix.
+
+DMPKGNAMEPREFIX=doom-
+
+.if !defined(ENGINE)
+PKGNAMEPREFIX?= ${DMPKGNAMEPREFIX}
+.endif
+
+# Dependency to "games/doom-data".
+
+.if ${PORTNAME} != "data"
+RUN_DEPENDS+= ${DMDIR}:${PORTSDIR}/games/doom-data
+.endif
+
+# Installation directories.
+
+DMDIR= ${PREFIX}/share/doom
+
+.if ${PORTNAME} == "data"
+DATADIR?= ${DMDIR}
+.endif
+
+.if ${PORTNAME} != "data" && !defined(ENGINE)
+DATADIR?= ${DMDIR}/${PORTNAME}
+.endif
+
+DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+PLIST_SUB+= DMDIR="${DMDIR:S/${PREFIX}\///}"
+SUB_LIST+= DMDIR="${DMDIR}"
diff --git a/games/doom-data/distinfo b/games/doom-data/distinfo
new file mode 100644
index 000000000000..037214dea8d6
--- /dev/null
+++ b/games/doom-data/distinfo
@@ -0,0 +1,12 @@
+MD5 (doom-data/doom1.wad.bz2) = c7fd38f3698110efadea1c9475736fdc
+SHA256 (doom-data/doom1.wad.bz2) = 415b18724d35cee07aa52f85bedc98ff28fd116c0c4d8ffe2031377e84543fad
+SIZE (doom-data/doom1.wad.bz2) = 1689027
+MD5 (doom-data/heretic1.wad.bz2) = 66462a87884aa00a41c0208bb152bbaa
+SHA256 (doom-data/heretic1.wad.bz2) = c45d071b204d8186996b1e168326b72f9ed41d76158bbd955e83790380ab03ae
+SIZE (doom-data/heretic1.wad.bz2) = 2218057
+MD5 (doom-data/hexen.wad.bz2) = 0478c38a75809b9bf1b604e6e688df4b
+SHA256 (doom-data/hexen.wad.bz2) = ab1244006eb71aec85b45f136a28b4d889dd9e50b5630aa23d72145a086eb821
+SIZE (doom-data/hexen.wad.bz2) = 4897389
+MD5 (doom-data/strife0.wad.bz2) = 7ce874f958c1538c8b96dd972e3d1fd0
+SHA256 (doom-data/strife0.wad.bz2) = 86d04b2128957d2ea972b7b22b84cb455d65bb70a4df2eee8ef3dbe0cadb002b
+SIZE (doom-data/strife0.wad.bz2) = 4051675
diff --git a/games/doom-data/files/pkg-message.in b/games/doom-data/files/pkg-message.in
new file mode 100644
index 000000000000..e67cba3d662f
--- /dev/null
+++ b/games/doom-data/files/pkg-message.in
@@ -0,0 +1,9 @@
+====================================================================
+
+To use the full version of the games you need to own a legitimate
+copy of Doom, Doom II, Hexen, Heretic and/or Strife.
+
+If you have them then copy the ".wad" files to
+%%DATADIR%%
+
+====================================================================
diff --git a/games/doom-data/pkg-descr b/games/doom-data/pkg-descr
new file mode 100644
index 000000000000..897054fd957d
--- /dev/null
+++ b/games/doom-data/pkg-descr
@@ -0,0 +1,6 @@
+Doom data files (Doom, Doom II, Hexen, Heretic, Strife).
+
+This port installs the data files needed to run Doom.
+
+You still need to have a legitimate copy of the game in order to obtain
+the full game, otherwise you can use the shareware version.
diff --git a/games/doom-data/pkg-plist b/games/doom-data/pkg-plist
new file mode 100644
index 000000000000..1c2adb61a767
--- /dev/null
+++ b/games/doom-data/pkg-plist
@@ -0,0 +1,5 @@
+%%DOOM%%%%DATADIR%%/doom1.wad
+%%HERETIC%%%%DATADIR%%/heretic1.wad
+%%HEXEN%%%%DATADIR%%/hexen.wad
+%%STRIFE%%%%DATADIR%%/strife0.wad
+@unexec rmdir %D/%%DATADIR%% >/dev/null 2>&1 || echo "If you are permanently removing this port, you should remove any WAD files left in %D/%%DATADIR%%." | fmt