aboutsummaryrefslogtreecommitdiff
path: root/games/doom
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-12-13 08:47:43 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-12-13 08:47:43 +0000
commit08a9ff8c98b4db96a514b13ce1bc98fc8240691a (patch)
tree758f6189aa67628fb949e44f1ba60296aabfc4b5 /games/doom
parent01fa0c28ea163b78c159bba7d631d3301e16f03a (diff)
downloadports-08a9ff8c98b4db96a514b13ce1bc98fc8240691a.tar.gz
ports-08a9ff8c98b4db96a514b13ce1bc98fc8240691a.zip
Don't write stuff to places other than ${WRKDIR}.
Notes
Notes: svn path=/head/; revision=15321
Diffstat (limited to 'games/doom')
-rw-r--r--games/doom/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/doom/Makefile b/games/doom/Makefile
index aa1111a84708..83b711667532 100644
--- a/games/doom/Makefile
+++ b/games/doom/Makefile
@@ -3,7 +3,7 @@
# Date created: Mon Dec 9 09:42:37 CST 1996
# Whom: erich@rrnet.com
#
-# $Id: Makefile,v 1.4 1997/07/13 18:49:14 max Exp $
+# $Id: Makefile,v 1.5 1997/11/29 00:49:08 jseger Exp $
#
DISTNAME= doom-1.8
@@ -17,19 +17,18 @@ MAINTAINER= erich@FreeBSD.org
BUILD_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_lib
RUN_DEPENDS= /compat/linux/lib/libc.so.5:${PORTSDIR}/emulators/linux_lib
+USE_XLIB= yes
NO_WRKSUBDIR= yes
+PKGINSTALL= ${WRKDIR}/INSTALL
post-patch:
@(cd ${WRKSRC}/joystick4doom; make clean)
@(cd ${WRKSRC}/musserver; make clean)
pre-install:
- @sed 's,@PREFIX@,${PREFIX},' ${PKGDIR}/INSTALL.in > ${PKGDIR}/INSTALL
+ @sed 's,@PREFIX@,${PREFIX},' ${PKGDIR}/INSTALL.in > ${PKGINSTALL}
post-install:
- @${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
-
-pre-clean:
- @rm -f ${PKGDIR}/INSTALL
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>