aboutsummaryrefslogtreecommitdiff
path: root/games/doomlegacy
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-02-18 10:18:33 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-02-18 10:18:33 +0000
commitfbd01976390528d38e2ffbe3df8037a79e26e972 (patch)
tree8144098cc3ca2dd1b78e333ab572429bc0046430 /games/doomlegacy
parente25425a4abd3a6a71133fb4845d5388f5f6a201a (diff)
downloadports-fbd01976390528d38e2ffbe3df8037a79e26e972.tar.gz
ports-fbd01976390528d38e2ffbe3df8037a79e26e972.zip
- Update devel/sdl12 to 1.2.15
- Update audio/sdl_mixer to 1.2.15 - Update graphics/sdl_image to 1.2.12 - Update graphics/sdl_ttf to 2.0.11 - Update graphics/sdl_gfx to 2.0.23 - Update net/sdl_net to 1.2.8 - Bump PORTREVISIONs on ports that depend on one or more packages due to ABI and shared library version changes - Update Mk/bsd.sdl.mk accordingly for the new shared library versions Tested by: exp-run by pav
Notes
Notes: svn path=/head/; revision=291667
Diffstat (limited to 'games/doomlegacy')
-rw-r--r--games/doomlegacy/Makefile2
-rw-r--r--games/doomlegacy/files/patch-i_sound.c47
2 files changed, 46 insertions, 3 deletions
diff --git a/games/doomlegacy/Makefile b/games/doomlegacy/Makefile
index f38ac8d151da..801d809a18b3 100644
--- a/games/doomlegacy/Makefile
+++ b/games/doomlegacy/Makefile
@@ -6,7 +6,7 @@
PORTNAME= doomlegacy
PORTVERSION= 142
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/DooM%20Legacy%20source%20code/1.42
DISTNAME= legacy_${PORTVERSION}_src
diff --git a/games/doomlegacy/files/patch-i_sound.c b/games/doomlegacy/files/patch-i_sound.c
index d847bb12cff8..ad6b62954e46 100644
--- a/games/doomlegacy/files/patch-i_sound.c
+++ b/games/doomlegacy/files/patch-i_sound.c
@@ -1,5 +1,5 @@
---- sdl/i_sound.c.orig Mon Apr 19 01:02:24 2004
-+++ sdl/i_sound.c Sat Mar 5 23:04:27 2005
+--- sdl/i_sound.c.orig 2004-04-18 23:02:24.000000000 +0200
++++ sdl/i_sound.c 2012-02-04 08:58:36.000000000 +0100
@@ -118,7 +118,7 @@
#define SAMPLERATE 11025 // Hz
@@ -9,3 +9,46 @@
static int lengths[NUMSFX]; // The actual lengths of all sound effects.
static unsigned int channelstep[NUM_CHANNELS]; // The channel step amount...
+@@ -517,12 +517,12 @@
+ // Mixing channel index.
+ int chan;
+
+- extern void music_mixer(void *udata, Uint8 * stream, int len);
++ //extern void music_mixer(void *udata, Uint8 * stream, int len);
+
+ if (nosound)
+ return;
+ // Mix in the music
+- music_mixer(NULL, stream, len);
++ //music_mixer(NULL, stream, len);
+
+ if (nosound)
+ return;
+@@ -709,14 +709,15 @@
+ /*
+ Should this be exposed in mixer.h?
+ */
+- extern void close_music(void);
++ //extern void close_music(void);
+ if (nomusic)
+ return;
+
+ if (!musicStarted)
+ return;
+
+- close_music();
++ //close_music();
++ Mix_CloseAudio();
+
+ CONS_Printf("I_ShutdownMusic: shut down\n");
+ musicStarted = false;
+@@ -740,7 +741,8 @@
+ if (nomusic)
+ return;
+
+- if (open_music(&audio) < 0)
++ //if (open_music(&audio) < 0)
++ if (Mix_OpenAudio (audio.freq, audio.format, audio.channels, audio.samples) < 0)
+ {
+ CONS_Printf("Unable to open music: %s\n", Mix_GetError());
+ nomusic = true;