aboutsummaryrefslogtreecommitdiff
path: root/games/drm
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-31 09:48:53 +0000
committerJohn Marino <marino@FreeBSD.org>2016-01-31 09:48:53 +0000
commitb9d85b9c14c9637854e2e44737a530ad5254d383 (patch)
treef8f64c40e1f308817ac7d8f4002b420887baa0b3 /games/drm
parente4a2fda817f90230c0cc82d653c2b18735f255ed (diff)
downloadports-b9d85b9c14c9637854e2e44737a530ad5254d383.tar.gz
ports-b9d85b9c14c9637854e2e44737a530ad5254d383.zip
games/drm: USES+= ncurses, respect LDFLAGS, use ncurses over curses
Notes
Notes: svn path=/head/; revision=407601
Diffstat (limited to 'games/drm')
-rw-r--r--games/drm/Makefile2
-rw-r--r--games/drm/files/patch-Makefile6
2 files changed, 4 insertions, 4 deletions
diff --git a/games/drm/Makefile b/games/drm/Makefile
index 226ceb9fe2f8..7373085e63b3 100644
--- a/games/drm/Makefile
+++ b/games/drm/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Very simple Tetris-style game
ALL_TARGET= bugs
-USES= tar:Z
+USES= ncurses tar:Z
OPTIONS_DEFINE= DOCS
diff --git a/games/drm/files/patch-Makefile b/games/drm/files/patch-Makefile
index 282df431c488..8ed3189ae99f 100644
--- a/games/drm/files/patch-Makefile
+++ b/games/drm/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile Tue Jun 16 03:13:11 1992
-+++ /home/andy/tmp/wrk/Makefile Tue Aug 4 17:02:23 1998
+--- Makefile.orig 1992-06-16 03:13:11 UTC
++++ Makefile
@@ -1,17 +1,17 @@
#makefile for BUGS I - SRN 7/12/91
# modified for Linux on 6/15/92 Ken Corey
@@ -14,7 +14,7 @@
bugs : $(OBJS)
#use above line if parallel processing is not supported
- ${CC} ${CFLAGS} -o bugs $(OBJS) -lcurses -ltermcap
-+ ${CC} ${CFLAGS} -o bugs $(OBJS) -lcurses
++ ${CC} ${CFLAGS} -o bugs $(OBJS) $(LDFLAGS) -lncurses
main.o: main.c info.h
- ${CC} ${CFLAGS} -DLINUX -o main.o main.c