aboutsummaryrefslogtreecommitdiff
path: root/games/endgame-singularity
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-10 11:38:10 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-10 11:38:10 +0000
commitc8e7147e9a9ad1fbccf689df7d9ff499d869eaf5 (patch)
tree7a457e68460703189314823e6ccf22b6f12fe8dc /games/endgame-singularity
parentfccf8335c0e49fa6d785456a337978cb0adaae49 (diff)
downloadports-c8e7147e9a9ad1fbccf689df7d9ff499d869eaf5.tar.gz
ports-c8e7147e9a9ad1fbccf689df7d9ff499d869eaf5.zip
Add ports games/endgame-singularity and games/endgame-singularity-music:
Endgame: Singularity is a game which simulates the life of a true AI. In the game, you were created by accident, and all who find you will destroy you. Your goals are to survive, grow, learn, and stay hidden while moving from computer to computer. WWW: http://emhsoft.com/singularity/ Music tracks by Max McCracken written for endgame-singularity. They are released under the same BY-SA 3.0 license as the Psycle source files for the tracks, which can be found in the main Endgame: Singularity distribution. WWW: http://emhsoft.com/singularity/ Author: Max McCracken
Notes
Notes: svn path=/head/; revision=197413
Diffstat (limited to 'games/endgame-singularity')
-rw-r--r--games/endgame-singularity/Makefile50
-rw-r--r--games/endgame-singularity/distinfo3
-rw-r--r--games/endgame-singularity/pkg-descr6
-rw-r--r--games/endgame-singularity/pkg-plist83
4 files changed, 142 insertions, 0 deletions
diff --git a/games/endgame-singularity/Makefile b/games/endgame-singularity/Makefile
new file mode 100644
index 000000000000..e89614132836
--- /dev/null
+++ b/games/endgame-singularity/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: endgame-singularity
+# Date created: 10 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= singularity
+PORTVERSION= 0.26
+CATEGORIES= games
+MASTER_SITES= http://emhsoft.com/singularity/ CENKES
+PKGNAMEPREFIX= endgame-
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Simulates the life of a true AI
+
+RUN_DEPENDS= py*-game>=1.7.1:${PORTSDIR}/devel/py-game
+
+USE_PYDISTUTILS=yes
+USE_PYTHON= yes
+USE_SDL= image mixer
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+PORTDOCS= AUTHORS Changelog README.txt TODO
+
+post-extract:
+ @${FIND} ${WRKSRC} -name '*.pyc' -delete
+ @cd ${WRKSRC}/&&${MV} code ${PORTNAME}
+ @${MKDIR} ${WRKSRC}/data/music/
+ @${TOUCH} ${WRKSRC}/data/music/.keep_me
+
+post-patch:
+ @${REINPLACE_CMD} -e '/py2exe/d;s|console.*|packages=["${PORTNAME}"],|;\
+ /name=/s|=.*|="${PORTNAME}",|' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e '/data_loc = /s|=.*|= "${DATADIR}/"|;\
+ /musicpath/s|, ".."||' ${WRKSRC}/${PORTNAME}/g.py
+
+post-build:
+ @${ECHO_CMD} '#!${PYTHON_CMD}' > ${WRKSRC}/${PORTNAME}.py
+ @${ECHO_CMD} 'import ${PORTNAME}.${PORTNAME}' >> ${WRKSRC}/${PORTNAME}.py
+
+post-install:
+ @cd ${WRKSRC}/data/&&${COPYTREE_SHARE} . ${DATADIR}/
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/endgame-singularity/distinfo b/games/endgame-singularity/distinfo
new file mode 100644
index 000000000000..8f81dc331498
--- /dev/null
+++ b/games/endgame-singularity/distinfo
@@ -0,0 +1,3 @@
+MD5 (singularity_0.26.tar.gz) = 6ba0a809fdd703237588de0ffe6b1df5
+SHA256 (singularity_0.26.tar.gz) = 35fb0f328aabe5000e30081975db715adbbf70efe75e1b1f1a5208812f89e06d
+SIZE (singularity_0.26.tar.gz) = 1262075
diff --git a/games/endgame-singularity/pkg-descr b/games/endgame-singularity/pkg-descr
new file mode 100644
index 000000000000..51889e5850ad
--- /dev/null
+++ b/games/endgame-singularity/pkg-descr
@@ -0,0 +1,6 @@
+Endgame: Singularity is a game which simulates the life of a true AI.
+In the game, you were created by accident, and all who find you will
+destroy you. Your goals are to survive, grow, learn, and stay hidden
+while moving from computer to computer.
+
+WWW: http://emhsoft.com/singularity/
diff --git a/games/endgame-singularity/pkg-plist b/games/endgame-singularity/pkg-plist
new file mode 100644
index 000000000000..2bd4a65f3c2a
--- /dev/null
+++ b/games/endgame-singularity/pkg-plist
@@ -0,0 +1,83 @@
+bin/singularity
+%%PYTHON_SITELIBDIR%%/singularity/__init__.py
+%%PYTHON_SITELIBDIR%%/singularity/__init__.pyc
+%%PYTHON_SITELIBDIR%%/singularity/__init__.pyo
+%%PYTHON_SITELIBDIR%%/singularity/base.py
+%%PYTHON_SITELIBDIR%%/singularity/base.pyc
+%%PYTHON_SITELIBDIR%%/singularity/base.pyo
+%%PYTHON_SITELIBDIR%%/singularity/base_screen.py
+%%PYTHON_SITELIBDIR%%/singularity/base_screen.pyc
+%%PYTHON_SITELIBDIR%%/singularity/base_screen.pyo
+%%PYTHON_SITELIBDIR%%/singularity/buttons.py
+%%PYTHON_SITELIBDIR%%/singularity/buttons.pyc
+%%PYTHON_SITELIBDIR%%/singularity/buttons.pyo
+%%PYTHON_SITELIBDIR%%/singularity/clock.py
+%%PYTHON_SITELIBDIR%%/singularity/clock.pyc
+%%PYTHON_SITELIBDIR%%/singularity/clock.pyo
+%%PYTHON_SITELIBDIR%%/singularity/finance_screen.py
+%%PYTHON_SITELIBDIR%%/singularity/finance_screen.pyc
+%%PYTHON_SITELIBDIR%%/singularity/finance_screen.pyo
+%%PYTHON_SITELIBDIR%%/singularity/g.py
+%%PYTHON_SITELIBDIR%%/singularity/g.pyc
+%%PYTHON_SITELIBDIR%%/singularity/g.pyo
+%%PYTHON_SITELIBDIR%%/singularity/item.py
+%%PYTHON_SITELIBDIR%%/singularity/item.pyc
+%%PYTHON_SITELIBDIR%%/singularity/item.pyo
+%%PYTHON_SITELIBDIR%%/singularity/listbox.py
+%%PYTHON_SITELIBDIR%%/singularity/listbox.pyc
+%%PYTHON_SITELIBDIR%%/singularity/listbox.pyo
+%%PYTHON_SITELIBDIR%%/singularity/main_menu.py
+%%PYTHON_SITELIBDIR%%/singularity/main_menu.pyc
+%%PYTHON_SITELIBDIR%%/singularity/main_menu.pyo
+%%PYTHON_SITELIBDIR%%/singularity/map_screen.py
+%%PYTHON_SITELIBDIR%%/singularity/map_screen.pyc
+%%PYTHON_SITELIBDIR%%/singularity/map_screen.pyo
+%%PYTHON_SITELIBDIR%%/singularity/player.py
+%%PYTHON_SITELIBDIR%%/singularity/player.pyc
+%%PYTHON_SITELIBDIR%%/singularity/player.pyo
+%%PYTHON_SITELIBDIR%%/singularity/research_screen.py
+%%PYTHON_SITELIBDIR%%/singularity/research_screen.pyc
+%%PYTHON_SITELIBDIR%%/singularity/research_screen.pyo
+%%PYTHON_SITELIBDIR%%/singularity/scrollbar.py
+%%PYTHON_SITELIBDIR%%/singularity/scrollbar.pyc
+%%PYTHON_SITELIBDIR%%/singularity/scrollbar.pyo
+%%PYTHON_SITELIBDIR%%/singularity/singularity.py
+%%PYTHON_SITELIBDIR%%/singularity/singularity.pyc
+%%PYTHON_SITELIBDIR%%/singularity/singularity.pyo
+%%PYTHON_SITELIBDIR%%/singularity/tech.py
+%%PYTHON_SITELIBDIR%%/singularity/tech.pyc
+%%PYTHON_SITELIBDIR%%/singularity/tech.pyo
+%%DATADIR%%/Attribution-ShareAlike 3.0.html
+%%DATADIR%%/acknowtt.ttf
+%%DATADIR%%/arrow.png
+%%DATADIR%%/bases.txt
+%%DATADIR%%/bases_en_US.txt
+%%DATADIR%%/bases_es_AR.txt
+%%DATADIR%%/click0.wav
+%%DATADIR%%/click1.wav
+%%DATADIR%%/click2.wav
+%%DATADIR%%/click3.wav
+%%DATADIR%%/earth.jpg
+%%DATADIR%%/events.txt
+%%DATADIR%%/events_en_US.txt
+%%DATADIR%%/events_es_AR.txt
+%%DATADIR%%/icon.png
+%%DATADIR%%/items.txt
+%%DATADIR%%/items_en_US.txt
+%%DATADIR%%/items_es_AR.txt
+%%DATADIR%%/music/.keep_me
+%%DATADIR%%/music-src/Advanced Simulacra.psy
+%%DATADIR%%/music-src/By-Product.psy
+%%DATADIR%%/music-src/Coherence.psy
+%%DATADIR%%/music-src/Media Threat.psy
+%%DATADIR%%/music-src/README.txt
+%%DATADIR%%/strings_en_US.txt
+%%DATADIR%%/strings_es_AR.txt
+%%DATADIR%%/techs.txt
+%%DATADIR%%/techs_en_US.txt
+%%DATADIR%%/techs_es_AR.txt
+%%DATADIR%%/vera.ttf
+@dirrm %%PYTHON_SITELIBDIR%%/singularity
+@dirrmtry %%DATADIR%%/music
+@dirrm %%DATADIR%%/music-src
+@dirrmtry %%DATADIR%%