aboutsummaryrefslogtreecommitdiff
path: root/games/endless-sky
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-08-21 12:44:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-08-21 12:44:09 +0000
commit2645b4c2b72d79427371791447c35f138ce56a04 (patch)
treef5dff7897753f8369837431f7aaab02ecd9086d5 /games/endless-sky
parentdbb6b553fca3701078cef13a1dfce3e7c504d63a (diff)
downloadports-2645b4c2b72d79427371791447c35f138ce56a04.tar.gz
ports-2645b4c2b72d79427371791447c35f138ce56a04.zip
- Update to 0.9.8
Notes
Notes: svn path=/head/; revision=448468
Diffstat (limited to 'games/endless-sky')
-rw-r--r--games/endless-sky/Makefile3
-rw-r--r--games/endless-sky/distinfo6
-rw-r--r--games/endless-sky/files/patch-source_CollisionSet.cpp11
3 files changed, 4 insertions, 16 deletions
diff --git a/games/endless-sky/Makefile b/games/endless-sky/Makefile
index f3e152bc178d..10453e27b16b 100644
--- a/games/endless-sky/Makefile
+++ b/games/endless-sky/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= endless-sky
-PORTVERSION= 0.9.6
-PORTREVISION= 2
+PORTVERSION= 0.9.8
DISTVERSIONPREFIX= v
CATEGORIES= games
diff --git a/games/endless-sky/distinfo b/games/endless-sky/distinfo
index a1949fb1c516..777a6a13a911 100644
--- a/games/endless-sky/distinfo
+++ b/games/endless-sky/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1487772910
-SHA256 (endless-sky-endless-sky-v0.9.6_GH0.tar.gz) = 41699dabb72a276c96019d0714e54492866e29661f161052a1caf334332be1e4
-SIZE (endless-sky-endless-sky-v0.9.6_GH0.tar.gz) = 71119557
+TIMESTAMP = 1503228209
+SHA256 (endless-sky-endless-sky-v0.9.8_GH0.tar.gz) = 69078c67656709646deb0c46fd960aa905601c23bb47c1696b0962ae8dff6d1e
+SIZE (endless-sky-endless-sky-v0.9.8_GH0.tar.gz) = 74476053
diff --git a/games/endless-sky/files/patch-source_CollisionSet.cpp b/games/endless-sky/files/patch-source_CollisionSet.cpp
index 5ec1dea45546..3d32f80de62e 100644
--- a/games/endless-sky/files/patch-source_CollisionSet.cpp
+++ b/games/endless-sky/files/patch-source_CollisionSet.cpp
@@ -8,14 +8,3 @@
using namespace std;
-@@ -179,8 +180,8 @@ Body *CollisionSet::Line(const Projectil
- int stepX = (x <= endX ? 1 : -1);
- int stepY = (y <= endY ? 1 : -1);
- // Calculate the slope of the line, shifted so it is positive in both axes.
-- int mx = abs(endX - x);
-- int my = abs(endY - y);
-+ int mx = std::abs(endX - x);
-+ int my = std::abs(endY - y);
- // Behave as if each grid cell has this width and height. This guarantees
- // that we only need to work with integer coordinates.
- int scale = max(mx, 1) * max(my, 1);