aboutsummaryrefslogtreecommitdiff
path: root/games/fheroes2/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-19 01:13:05 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-19 01:13:05 +0000
commit438011d8714e5fece54f5bfabe51b40793fe5b13 (patch)
treef2508ee4bee502207be94d380374eafa44008bf9 /games/fheroes2/Makefile
parent8ffa3a106e57c57f2611ebfc51f1e4ff2487ca54 (diff)
downloadports-438011d8714e5fece54f5bfabe51b40793fe5b13.tar.gz
ports-438011d8714e5fece54f5bfabe51b40793fe5b13.zip
games/fheroes2: Free implementation of Heroes of Might and Magic II game engine
Notes
Notes: svn path=/head/; revision=561996
Diffstat (limited to 'games/fheroes2/Makefile')
-rw-r--r--games/fheroes2/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/games/fheroes2/Makefile b/games/fheroes2/Makefile
new file mode 100644
index 000000000000..a8d53bc71143
--- /dev/null
+++ b/games/fheroes2/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= fheroes2
+PORTVERSION= 0.8.4
+CATEGORIES= games
+
+MAINTAINER= pkubaj@FreeBSD.org
+COMMENT= Free implementation of Heroes of Might and Magic II engine
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libtinyxml.so:textproc/tinyxml
+
+USES= gettext-tools gmake sdl
+USE_GITHUB= yes
+GH_ACCOUNT= ihhub
+USE_SDL= image2 mixer2 sdl2 ttf2
+
+LDFLAGS+= -ltinyxml
+MAKE_ENV= WITHOUT_BUNDLED_LIBS=1 \
+ WITH_SDL2=1
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>