aboutsummaryrefslogtreecommitdiff
path: root/games/filters
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-07 08:57:37 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-07 08:57:37 +0000
commit61ebd1776e3aee5a447d2d50b615c992349d1d6f (patch)
tree5a642a5ba2fc1ad06490c6b27a9c4b611eb25492 /games/filters
parenta5862b83094e3fa745bae0c83861afc4a3090436 (diff)
downloadports-61ebd1776e3aee5a447d2d50b615c992349d1d6f.tar.gz
ports-61ebd1776e3aee5a447d2d50b615c992349d1d6f.zip
Convert to use shebangfix USES flag.
Notes
Notes: svn path=/head/; revision=317591
Diffstat (limited to 'games/filters')
-rw-r--r--games/filters/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/games/filters/Makefile b/games/filters/Makefile
index 5cc2723316c3..83012a5ac23e 100644
--- a/games/filters/Makefile
+++ b/games/filters/Makefile
@@ -14,6 +14,7 @@ COMMENT= Collection of filters, including B1FF, and the Swedish Chef
CONFLICTS= talkfilters-[0-9]* jive-[0-9]* chef-[0-9]* kenny-[0-9]* \
lolcat-[0-9]*
+USES= shebangfix
USE_PERL5= yes
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
@@ -25,6 +26,8 @@ PERLFILTERS= b1ff censor chef eleet fudd jibberish kenny pirate rasterman \
CFILTERS= jethro kraut cockney jive nyc ken ky00te newspeak nethackify \
scramble
+SHEBANG_FILES= ${PERLFILTERS}
+
MAN1= filters.1
MLINKS= filters.1 b1ff.1 \
filters.1 censor.1 \
@@ -55,11 +58,6 @@ MLINKS= filters.1 b1ff.1 \
post-extract:
@${MV} ${WRKSRC}/${PORTNAME}.6 ${WRKSRC}/${MAN1}
-post-patch:
-.for f in ${PERLFILTERS}
- @${REINPLACE_CMD} -e '1s|.*perl|#!${PERL}|' ${WRKSRC}/${f}
-.endfor
-
do-install:
.for f in ${CFILTERS}
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin