aboutsummaryrefslogtreecommitdiff
path: root/games/filters
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2015-09-03 20:40:14 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2015-09-03 20:40:14 +0000
commitc90e5002a48c561124a3f2d4f0bc9e5a7b73fe7e (patch)
treed92f08df0641baf123d15f11a8b0b9cf7cf4f20e /games/filters
parent53899a49298007bcc4dfcf1f5635348fd297ad33 (diff)
downloadports-c90e5002a48c561124a3f2d4f0bc9e5a7b73fe7e.tar.gz
ports-c90e5002a48c561124a3f2d4f0bc9e5a7b73fe7e.zip
- Update to 2.54
- Sort USES
Notes
Notes: svn path=/head/; revision=396043
Diffstat (limited to 'games/filters')
-rw-r--r--games/filters/Makefile5
-rw-r--r--games/filters/distinfo4
-rw-r--r--games/filters/files/patch-Makefile74
-rw-r--r--games/filters/files/patch-filters.16
-rw-r--r--games/filters/files/patch-ky00te.dir__makefile11
-rw-r--r--games/filters/files/patch-nethackify.dir__makefile11
6 files changed, 17 insertions, 94 deletions
diff --git a/games/filters/Makefile b/games/filters/Makefile
index 9aad4e88592d..4ce45609e030 100644
--- a/games/filters/Makefile
+++ b/games/filters/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= filters
-PORTVERSION= 2.53
+PORTVERSION= 2.54
CATEGORIES= games perl5
MASTER_SITES= http://ftp.debian.org/debian/pool/main/f/filters/ \
LOCAL/ehaupt
@@ -13,8 +13,7 @@ COMMENT= Collection of filters, including B1FF, and the Swedish Chef
CONFLICTS= talkfilters-[0-9]* jive-[0-9]* chef-[0-9]* kenny-[0-9]*
-USES= shebangfix gmake perl5
-MAKE_JOBS_UNSAFE= yes
+USES= gmake perl5 shebangfix
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/filters/distinfo b/games/filters/distinfo
index 97b8a3e364dd..b5ac65244b25 100644
--- a/games/filters/distinfo
+++ b/games/filters/distinfo
@@ -1,2 +1,2 @@
-SHA256 (filters_2.53.tar.gz) = 008d9bc90add21bdebf5e85445a66f37bee3d6237c85c8348ed742d3c4b7c8b7
-SIZE (filters_2.53.tar.gz) = 55332
+SHA256 (filters_2.54.tar.gz) = 2e0dc1c5206e36540b0f8ed2d8462c78b56211c53af131ae8c3be338d0ae13e6
+SIZE (filters_2.54.tar.gz) = 54198
diff --git a/games/filters/files/patch-Makefile b/games/filters/files/patch-Makefile
index 42a1a21ae3ec..bd4ea19de10c 100644
--- a/games/filters/files/patch-Makefile
+++ b/games/filters/files/patch-Makefile
@@ -1,74 +1,20 @@
---- Makefile.orig 2014-09-10 09:44:18.886311642 +0200
-+++ Makefile 2014-09-10 09:44:13.089316817 +0200
-@@ -1,9 +1,10 @@
- LEX = flex
- BUILD = jethro kraut cockney jive nyc ken ky00te newspeak nethackify scramble
- OTHER = eleet b1ff chef jibberish upside-down rasterman studly fudd \
-- censor spammer uniencode pirate kenny scottish fanboy LOLCAT
--CFLAGS = -O2 -lfl
-+ censor spammer uniencode pirate kenny scottish fanboy
-+LDFLAGS+= -lfl
- export CFLAGS
-+export LDFLAGS
- INSTALL_PROGRAM = install
-
- # DEB_BUILD_OPTIONS suport, to control binary stripping.
-@@ -19,13 +20,9 @@
- all: $(OTHER) $(BUILD) samples
-
- install: $(BUILD) $(OTHER)
-- install -d $(DESTDIR)/usr/games
-- $(INSTALL_PROGRAM) $(BUILD) $(DESTDIR)/usr/games/
-- install $(OTHER) $(DESTDIR)/usr/games/
-- install -d $(DESTDIR)/usr/share/man/man6
-- install -m 0644 filters.6 $(DESTDIR)/usr/share/man/man6
-- cd $(DESTDIR)/usr/share/man/man6 && \
-- $(foreach prog,$(BUILD) $(OTHER),ln -s filters.6 $(prog).6;)
-+ install -d $(DESTDIR)/$(PREFIX)/bin
-+ $(INSTALL_PROGRAM) $(BUILD) $(DESTDIR)/$(PREFIX)/bin
-+ install $(OTHER) $(DESTDIR)/$(PREFIX)/bin
-
- samples: $(BUILD) $(OTHER)
- -rm -f SAMPLES
-@@ -33,33 +30,33 @@
+--- Makefile.orig 2015-09-03 20:26:09 UTC
++++ Makefile
+@@ -27,7 +27,7 @@ install: $(BUILD) $(OTHER)
clean:
- $(RM) -f core *.o *~ $(BUILD) SAMPLES
+ $(RM) -f core *.o *~ $(BUILD)
- cd ky00te.dir && make clean
-+ cd ky00te.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS) clean
- rm -f kraut.dir/lex.yy.c
-- cd nethackify.dir && make clean
-- cd scramble.dir && make clean
-+ cd nethackify.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS) clean
-+ cd scramble.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS) clean
++ cd ky00te.dir && $(MAKE_ENV) $(MAKE) clean
.SUFFIXES: .l
- .l:
- $(RM) $*.c
- $(LEX) -t $< > $*.c
-- $(CC) -o $@ $*.c $(CFLAGS)
-+ $(CC) -o $@ $*.c $(CFLAGS) $(LDFLAGS)
- $(RM) $*.c
-
+@@ -40,7 +40,7 @@ clean:
.SUFFIXES: .dir
- .dir:
+ .dir:
- cd $<; make
-+ cd $<; $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS)
-
- ky00te:
-- cd ky00te.dir && make
-+ cd ky00te.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS)
-
- kraut:
- cd kraut.dir && lex kraut.l
- cd kraut.dir && $(CC) kraut.c lex.yy.c -o ../kraut
-
- nethackify:
-- cd nethackify.dir && make
-+ cd nethackify.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS)
++ cd $<; $(MAKE_ENV) $(MAKE)
- scramble:
-- cd scramble.dir && make
-+ cd scramble.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS)
+ nethackify: nethackify.c
+ scramble: scramble.c
diff --git a/games/filters/files/patch-filters.1 b/games/filters/files/patch-filters.1
index 9167c9725da7..2a6bb78f52bd 100644
--- a/games/filters/files/patch-filters.1
+++ b/games/filters/files/patch-filters.1
@@ -1,8 +1,8 @@
---- ./filters.1.orig 2010-02-18 19:56:50.000000000 +0100
-+++ ./filters.1 2011-02-14 14:33:09.000000000 +0100
+--- filters.1.orig 2015-08-30 21:50:41 UTC
++++ filters.1
@@ -1,4 +1,4 @@
-.TH FILTERS 6
+.TH FILTERS 1
.SH NAME
- ken, b1ff, censor, chef, cockney, eleet, fanboy, fudd, jethro, jibberish, jive, kenny, kraut, ky00te, nethack, newspeak, nyc, pirate, rasterman, scottish, spammer, scramble, studly, uniencode, upside\-down \- assorted text filters
+ ken, b1ff, censor, chef, cockney, eleet, fanboy, fudd, jethro, jibberish, jive, kenny, kraut, ky00te, nethackify, newspeak, nyc, pirate, rasterman, scottish, spammer, scramble, studly, uniencode, upside\-down \- assorted text filters
.SH SYNOPSIS
diff --git a/games/filters/files/patch-ky00te.dir__makefile b/games/filters/files/patch-ky00te.dir__makefile
deleted file mode 100644
index 0cf6a97ec141..000000000000
--- a/games/filters/files/patch-ky00te.dir__makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./ky00te.dir/makefile.orig 2008-12-17 00:16:04.000000000 +0100
-+++ ./ky00te.dir/makefile 2011-02-14 14:33:09.000000000 +0100
-@@ -5,7 +5,7 @@
- rm -f ../ky00te
-
- ../ky00te: y.tab.o lex.yy.o
-- $(CC) -o ../ky00te lex.yy.o y.tab.o $(CFLAGS)
-+ $(CC) -o ../ky00te lex.yy.o y.tab.o $(CFLAGS) $(LDFLAGS)
-
- lex.yy.o: lex.yy.c y.tab.h
- $(CC) $(CFLAGS) -c lex.yy.c
diff --git a/games/filters/files/patch-nethackify.dir__makefile b/games/filters/files/patch-nethackify.dir__makefile
deleted file mode 100644
index 2fc0e89dd81d..000000000000
--- a/games/filters/files/patch-nethackify.dir__makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./nethackify.dir/makefile.orig 2008-12-17 00:16:04.000000000 +0100
-+++ ./nethackify.dir/makefile 2011-02-14 14:33:09.000000000 +0100
-@@ -1,5 +1,7 @@
-+CFLAGS+= -trigraphs
-+
- ../nethackify:
-- gcc nethackify.c -o ../nethackify
-+ $(CC) $(CFLAGS) nethackify.c -o ../nethackify
-
- test:
- @../nethackify The kitten bites.--More--