aboutsummaryrefslogtreecommitdiff
path: root/games/filters
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-02-14 13:55:38 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-02-14 13:55:38 +0000
commite249b762781901dea5bfa7948ceeaa3a1a157f47 (patch)
tree37d36fe83ff3ca0fac3137d5bd32e75169b879f5 /games/filters
parent7fa0a038b7f79ea21066c04835fc4754fac6f930 (diff)
downloadports-e249b762781901dea5bfa7948ceeaa3a1a157f47.tar.gz
ports-e249b762781901dea5bfa7948ceeaa3a1a157f47.zip
Update to 2.48
Feature safe: yes
Notes
Notes: svn path=/head/; revision=269148
Diffstat (limited to 'games/filters')
-rw-r--r--games/filters/Makefile14
-rw-r--r--games/filters/distinfo5
-rw-r--r--games/filters/files/patch-Makefile58
-rw-r--r--games/filters/files/patch-filters.16
-rw-r--r--games/filters/files/patch-ky00te.dir__makefile4
-rw-r--r--games/filters/files/patch-nethackify.dir__makefile4
-rw-r--r--games/filters/pkg-plist3
7 files changed, 75 insertions, 19 deletions
diff --git a/games/filters/Makefile b/games/filters/Makefile
index da2691bec3c9..85ae9cafe857 100644
--- a/games/filters/Makefile
+++ b/games/filters/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= filters
-PORTVERSION= 2.46
+PORTVERSION= 2.48
CATEGORIES= games perl5
MASTER_SITES= http://ftp.debian.org/debian/pool/main/f/filters/ \
CRITICAL
@@ -24,11 +24,12 @@ MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PERLFILTERS= b1ff censor chef eleet fudd jibberish kenny pirate rasterman \
- spammer studly uniencode upside-down
-CFILTERS= jethro kraut cockney jive nyc ken ky00te newspeak nethackify
+ spammer studly uniencode upside-down fanboy scottish
+CFILTERS= jethro kraut cockney jive nyc ken ky00te newspeak nethackify \
+ scramble
MAN1= filters.1
-MLINKS= filters.1 b1ff.1 \
+MLINKS= filters.1 b1ff.1 \
filters.1 censor.1 \
filters.1 chef.1 \
filters.1 eleet.1 \
@@ -49,7 +50,10 @@ MLINKS= filters.1 b1ff.1 \
filters.1 ken.1 \
filters.1 ky00te.1 \
filters.1 newspeak.1 \
- filters.1 nethackify.1
+ filters.1 nethackify.1 \
+ filters.1 fanboy.1 \
+ filters.1 scottish.1 \
+ filters.1 scramble.1
post-extract:
@${MV} ${WRKSRC}/${PORTNAME}.6 ${WRKSRC}/${MAN1}
diff --git a/games/filters/distinfo b/games/filters/distinfo
index de7b9c7d6219..a6f6f20dccde 100644
--- a/games/filters/distinfo
+++ b/games/filters/distinfo
@@ -1,3 +1,2 @@
-MD5 (filters_2.46.tar.gz) = 4eb1c6d80876b81f19b7b38012ec6e05
-SHA256 (filters_2.46.tar.gz) = 8cc469537992f8be566e973de856847f46da75b7efe10a1da36c9928968546dd
-SIZE (filters_2.46.tar.gz) = 51431
+SHA256 (filters_2.48.tar.gz) = 25b588a47b7ac73380af99adc39a85d358a4348fccbf68afe46e17994ac68a58
+SIZE (filters_2.48.tar.gz) = 54839
diff --git a/games/filters/files/patch-Makefile b/games/filters/files/patch-Makefile
index 81d3d7b4a56c..85f2f84cef6d 100644
--- a/games/filters/files/patch-Makefile
+++ b/games/filters/files/patch-Makefile
@@ -1,7 +1,7 @@
---- ./Makefile.orig 2008-04-14 19:22:29.000000000 +0200
-+++ ./Makefile 2008-04-29 15:59:17.000000000 +0200
+--- ./Makefile.orig 2009-07-11 22:18:22.000000000 +0200
++++ ./Makefile 2011-02-14 14:34:38.000000000 +0100
@@ -2,8 +2,9 @@
- BUILD = jethro kraut cockney jive nyc ken ky00te newspeak nethackify
+ BUILD = jethro kraut cockney jive nyc ken ky00te newspeak nethackify scramble
OTHER = eleet b1ff chef jibberish upside-down rasterman studly fudd \
censor spammer uniencode pirate kenny scottish fanboy
-CFLAGS = -O2 -lfl
@@ -11,7 +11,37 @@
INSTALL_PROGRAM = install
# DEB_BUILD_OPTIONS suport, to control binary stripping.
-@@ -42,7 +43,7 @@
+@@ -19,13 +20,9 @@
+ all: $(OTHER) $(BUILD) samples
+
+ install: $(BUILD) $(OTHER)
+- install -d $(DESTDIR)/usr/games
+- $(INSTALL_PROGRAM) $(BUILD) $(DESTDIR)/usr/games/
+- install $(OTHER) $(DESTDIR)/usr/games/
+- install -d $(DESTDIR)/usr/share/man/man6
+- install -m 0644 filters.6 $(DESTDIR)/usr/share/man/man6
+- cd $(DESTDIR)/usr/share/man/man6 && \
+- $(foreach prog,$(BUILD) $(OTHER),ln -s filters.6 $(prog).6;)
++ install -d $(DESTDIR)/$(PREFIX)/bin
++ $(INSTALL_PROGRAM) $(BUILD) $(DESTDIR)/$(PREFIX)/bin
++ install $(OTHER) $(DESTDIR)/$(PREFIX)/bin
+
+ samples: $(BUILD) $(OTHER)
+ -rm -f SAMPLES
+@@ -33,33 +30,33 @@
+
+ clean:
+ $(RM) -f core *.o *~ $(BUILD) SAMPLES
+- cd ky00te.dir && make clean
++ cd ky00te.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS) clean
+ rm -f kraut.dir/lex.yy.c
+- cd nethackify.dir && make clean
+- cd scramble.dir && make clean
++ cd nethackify.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS) clean
++ cd scramble.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS) clean
+
+ .SUFFIXES: .l
+
.l:
$(RM) $*.c
$(LEX) -t $< > $*.c
@@ -20,3 +50,23 @@
$(RM) $*.c
.SUFFIXES: .dir
+
+ .dir:
+- cd $<; make
++ cd $<; $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS)
+
+ ky00te:
+- cd ky00te.dir && make
++ cd ky00te.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS)
+
+ kraut:
+ cd kraut.dir && lex kraut.l
+ cd kraut.dir && $(CC) kraut.c lex.yy.c -o ../kraut
+
+ nethackify:
+- cd nethackify.dir && make
++ cd nethackify.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS)
+
+ scramble:
+- cd scramble.dir && make
++ cd scramble.dir && $(SETENV) $(MAKE_ENV) $(MAKE) $(MAKE_FLAGS)
diff --git a/games/filters/files/patch-filters.1 b/games/filters/files/patch-filters.1
index 07a62511f0ee..9167c9725da7 100644
--- a/games/filters/files/patch-filters.1
+++ b/games/filters/files/patch-filters.1
@@ -1,8 +1,8 @@
---- ./filters.1.orig Tue Jan 2 18:06:45 2007
-+++ ./filters.1 Tue Jan 2 18:06:51 2007
+--- ./filters.1.orig 2010-02-18 19:56:50.000000000 +0100
++++ ./filters.1 2011-02-14 14:33:09.000000000 +0100
@@ -1,4 +1,4 @@
-.TH FILTERS 6
+.TH FILTERS 1
.SH NAME
- ken, b1ff, censor, chef, cockney, eleet, fudd, jethro, jibberish, jive, kenny, kraut, ky00te, nethack, newspeak, nyc, pirate, rasterman, spammer, studly, uniencode, upside\-down \- assorted text filters
+ ken, b1ff, censor, chef, cockney, eleet, fanboy, fudd, jethro, jibberish, jive, kenny, kraut, ky00te, nethack, newspeak, nyc, pirate, rasterman, scottish, spammer, scramble, studly, uniencode, upside\-down \- assorted text filters
.SH SYNOPSIS
diff --git a/games/filters/files/patch-ky00te.dir__makefile b/games/filters/files/patch-ky00te.dir__makefile
index 59ebb2a2d3c0..0cf6a97ec141 100644
--- a/games/filters/files/patch-ky00te.dir__makefile
+++ b/games/filters/files/patch-ky00te.dir__makefile
@@ -1,5 +1,5 @@
---- ./ky00te.dir/makefile.orig 2008-04-14 19:21:51.000000000 +0200
-+++ ./ky00te.dir/makefile 2008-04-29 15:58:59.000000000 +0200
+--- ./ky00te.dir/makefile.orig 2008-12-17 00:16:04.000000000 +0100
++++ ./ky00te.dir/makefile 2011-02-14 14:33:09.000000000 +0100
@@ -5,7 +5,7 @@
rm -f ../ky00te
diff --git a/games/filters/files/patch-nethackify.dir__makefile b/games/filters/files/patch-nethackify.dir__makefile
index ad14228b2df6..2fc0e89dd81d 100644
--- a/games/filters/files/patch-nethackify.dir__makefile
+++ b/games/filters/files/patch-nethackify.dir__makefile
@@ -1,5 +1,5 @@
---- ./nethackify.dir/makefile.orig Wed Jan 25 05:54:47 2006
-+++ ./nethackify.dir/makefile Tue Jan 2 18:06:34 2007
+--- ./nethackify.dir/makefile.orig 2008-12-17 00:16:04.000000000 +0100
++++ ./nethackify.dir/makefile 2011-02-14 14:33:09.000000000 +0100
@@ -1,5 +1,7 @@
+CFLAGS+= -trigraphs
+
diff --git a/games/filters/pkg-plist b/games/filters/pkg-plist
index 62baf4956e9f..ce085efb0aa0 100644
--- a/games/filters/pkg-plist
+++ b/games/filters/pkg-plist
@@ -3,6 +3,7 @@ bin/censor
bin/chef
bin/cockney
bin/eleet
+bin/fanboy
bin/fudd
bin/jethro
bin/jibberish
@@ -16,6 +17,8 @@ bin/newspeak
bin/nyc
bin/pirate
bin/rasterman
+bin/scottish
+bin/scramble
bin/spammer
bin/studly
bin/uniencode