aboutsummaryrefslogtreecommitdiff
path: root/games/flyhard
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-04 01:40:00 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-04 01:40:00 +0000
commit0b5aa56821f14f87549202848a85801f5732eda0 (patch)
treea2eeeddaec0b7e26edc065e97f3f92405601727a /games/flyhard
parentb35f73b2d3993a346cb959cb45562a133388fbbb (diff)
downloadports-0b5aa56821f14f87549202848a85801f5732eda0.tar.gz
ports-0b5aa56821f14f87549202848a85801f5732eda0.zip
- Support staging
- Convert USE_GMAKE to USES - Use new LIB_DEPENDS syntax
Notes
Notes: svn path=/head/; revision=329254
Diffstat (limited to 'games/flyhard')
-rw-r--r--games/flyhard/Makefile17
-rw-r--r--games/flyhard/pkg-plist125
2 files changed, 9 insertions, 133 deletions
diff --git a/games/flyhard/Makefile b/games/flyhard/Makefile
index 265679c2662f..50657582cf06 100644
--- a/games/flyhard/Makefile
+++ b/games/flyhard/Makefile
@@ -11,27 +11,28 @@ MASTER_SITES= http://www.markboyd.me.uk/games/flyhard/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Game resembling Thrust, but with lots of shooting and puzzles
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_SDL= sdl mixer
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-PORTDOCS= README
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= *
+PORTDATA= *
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/flyhard/pkg-plist b/games/flyhard/pkg-plist
deleted file mode 100644
index 67d97837ea30..000000000000
--- a/games/flyhard/pkg-plist
+++ /dev/null
@@ -1,125 +0,0 @@
-bin/flyhard
-%%DATADIR%%/images/ast_ufo.png
-%%DATADIR%%/images/asteroid1.png
-%%DATADIR%%/images/asteroid2.png
-%%DATADIR%%/images/asteroid3.png
-%%DATADIR%%/images/baby_graldor.png
-%%DATADIR%%/images/ball.png
-%%DATADIR%%/images/block.png
-%%DATADIR%%/images/blockdiag_bl.png
-%%DATADIR%%/images/blockdiag_br.png
-%%DATADIR%%/images/blockdiag_tl.png
-%%DATADIR%%/images/blockdiag_tr.png
-%%DATADIR%%/images/blockexplo0.png
-%%DATADIR%%/images/blockexplo1.png
-%%DATADIR%%/images/blockexplo2.png
-%%DATADIR%%/images/blockexplo3.png
-%%DATADIR%%/images/bobbler.png
-%%DATADIR%%/images/buttond1.png
-%%DATADIR%%/images/buttond2.png
-%%DATADIR%%/images/buttond3.png
-%%DATADIR%%/images/buttonl1.png
-%%DATADIR%%/images/buttonl2.png
-%%DATADIR%%/images/buttonl3.png
-%%DATADIR%%/images/buttonr1.png
-%%DATADIR%%/images/buttonr2.png
-%%DATADIR%%/images/buttonr3.png
-%%DATADIR%%/images/buttonu1.png
-%%DATADIR%%/images/buttonu2.png
-%%DATADIR%%/images/buttonu3.png
-%%DATADIR%%/images/coin.png
-%%DATADIR%%/images/engine_point.png
-%%DATADIR%%/images/font.png
-%%DATADIR%%/images/graldor0.png
-%%DATADIR%%/images/graldor1.png
-%%DATADIR%%/images/graldor2.png
-%%DATADIR%%/images/graldor3.png
-%%DATADIR%%/images/graldor4.png
-%%DATADIR%%/images/graldor5.png
-%%DATADIR%%/images/graldor6.png
-%%DATADIR%%/images/graldor7.png
-%%DATADIR%%/images/graldor8.png
-%%DATADIR%%/images/graldor9.png
-%%DATADIR%%/images/heart.png
-%%DATADIR%%/images/hgate1.png
-%%DATADIR%%/images/hgate2.png
-%%DATADIR%%/images/hgate3.png
-%%DATADIR%%/images/hgate4.png
-%%DATADIR%%/images/hgate5.png
-%%DATADIR%%/images/hgateclosed.png
-%%DATADIR%%/images/hgateopen.png
-%%DATADIR%%/images/invader1.png
-%%DATADIR%%/images/invader2.png
-%%DATADIR%%/images/miner.png
-%%DATADIR%%/images/peashooter.png
-%%DATADIR%%/images/pipe_+.png
-%%DATADIR%%/images/pipe_Td.png
-%%DATADIR%%/images/pipe_Tl.png
-%%DATADIR%%/images/pipe_Tr.png
-%%DATADIR%%/images/pipe_Tu.png
-%%DATADIR%%/images/pipe_ld.png
-%%DATADIR%%/images/pipe_lr.png
-%%DATADIR%%/images/pipe_lu.png
-%%DATADIR%%/images/pipe_rd.png
-%%DATADIR%%/images/pipe_ru.png
-%%DATADIR%%/images/pipe_ud.png
-%%DATADIR%%/images/plasmoid.png
-%%DATADIR%%/images/recking_ball.png
-%%DATADIR%%/images/rocket.png
-%%DATADIR%%/images/s_battery.png
-%%DATADIR%%/images/s_generator.png
-%%DATADIR%%/images/s_generator2.png
-%%DATADIR%%/images/s_implosion.png
-%%DATADIR%%/images/s_lead.png
-%%DATADIR%%/images/s_plasmoid.png
-%%DATADIR%%/images/s_rapishooter.png
-%%DATADIR%%/images/s_rbg.png
-%%DATADIR%%/images/s_rocket.png
-%%DATADIR%%/images/s_scatter.png
-%%DATADIR%%/images/s_scoop.png
-%%DATADIR%%/images/s_shover.png
-%%DATADIR%%/images/s_sniper.png
-%%DATADIR%%/images/s_system_mount.png
-%%DATADIR%%/images/ship.png
-%%DATADIR%%/images/shop.png
-%%DATADIR%%/images/shot.png
-%%DATADIR%%/images/shover.png
-%%DATADIR%%/images/sink.png
-%%DATADIR%%/images/source.png
-%%DATADIR%%/images/t_shot.png
-%%DATADIR%%/images/title.png
-%%DATADIR%%/images/tractor.png
-%%DATADIR%%/images/transpixel.png
-%%DATADIR%%/images/turret_down.png
-%%DATADIR%%/images/turret_left.png
-%%DATADIR%%/images/turret_right.png
-%%DATADIR%%/images/turret_up.png
-%%DATADIR%%/images/ufo.png
-%%DATADIR%%/images/vgate1.png
-%%DATADIR%%/images/vgate2.png
-%%DATADIR%%/images/vgate3.png
-%%DATADIR%%/images/vgate4.png
-%%DATADIR%%/images/vgate5.png
-%%DATADIR%%/images/vgateclosed.png
-%%DATADIR%%/images/vgateopen.png
-%%DATADIR%%/images/wcircle50.png
-%%DATADIR%%/images/wcircle_100.png
-%%DATADIR%%/images/weapon_point.png
-%%DATADIR%%/images/wshot.png
-%%DATADIR%%/levels/levels.txt
-%%DATADIR%%/save/scores
-%%DATADIR%%/sounds/boom.wav
-%%DATADIR%%/sounds/bounce.wav
-%%DATADIR%%/sounds/cashregister.wav
-%%DATADIR%%/sounds/clang.wav
-%%DATADIR%%/sounds/kaboom.wav
-%%DATADIR%%/sounds/pop.wav
-%%DATADIR%%/sounds/shatter.wav
-%%DATADIR%%/sounds/slurp.wav
-%%DATADIR%%/sounds/whitebass25.wav
-%%DATADIR%%/sounds/whiteout25.wav
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%/save
-@dirrm %%DATADIR%%/levels
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%