aboutsummaryrefslogtreecommitdiff
path: root/games/fretsonfire/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-03 17:42:13 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-03 17:42:13 +0000
commit60bc02573ec7407a45cd13f3888bb4b4faaf920c (patch)
tree5f8d4ad281393f7cc442ee0a5c384e8f26eeab52 /games/fretsonfire/Makefile
parentba0a7a10d5f4e3bd727919a964552ef022ec24fa (diff)
downloadports-60bc02573ec7407a45cd13f3888bb4b4faaf920c.tar.gz
ports-60bc02573ec7407a45cd13f3888bb4b4faaf920c.zip
- New ports: games/fretsonfire and games/fretsonfire-data
Frets on Fire is a game of musical skill and fast fingers. The aim of the game is to play guitar with the keyboard as accurately as possible. WWW: http://louhi.kempele.fi/~skyostil/uv/fretsonfire/
Notes
Notes: svn path=/head/; revision=174385
Diffstat (limited to 'games/fretsonfire/Makefile')
-rw-r--r--games/fretsonfire/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/games/fretsonfire/Makefile b/games/fretsonfire/Makefile
new file mode 100644
index 000000000000..afab94e9a37e
--- /dev/null
+++ b/games/fretsonfire/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: fretsonfire
+# Date created: 2006-09-01
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fretsonfire
+PORTVERSION= 1.0.225
+CATEGORIES= games python
+MASTER_SITES= http://louhi.kempele.fi/~skyostil/uv/fretsonfire/dist/
+DISTNAME= ${PORTNAME:S/f/F/g:S/o/O/}-${PORTVERSION:S/^/src-/}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= A game of musical skill and fast fingers
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric/_numpy.so:${PORTSDIR}/math/py-numeric \
+ ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game \
+ ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl \
+ ${PYTHON_SITELIBDIR}/amanith.py:${PORTSDIR}/graphics/py-amanith \
+ ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging \
+ ${PYTHON_SITELIBDIR}/glew/__init__.py:${PORTSDIR}/graphics/py-glewpy \
+ ${LOCALBASE}/share/${PORTNAME}/default.ttf:${PORTSDIR}/games/fretsonfire-data
+
+USE_PYTHON= yes
+NO_BUILD= yes
+DATADIR= share/${PORTNAME}
+FOF_DIR= ${PREFIX}/lib/${PORTNAME}
+SUB_FILES= pkg-message FretsOnFire
+SUB_LIST= PROGRAM_DIR="${FOF_DIR}/${PORTNAME:S/f/F/g:S/o/O/}"
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+WITHOUT_PSYCO= yes
+.endif
+
+.if !defined(WITHOUT_PSYCO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
+.endif
+
+do-install:
+ ${MKDIR} ${FOF_DIR}/${PORTNAME:S/f/F/g:S/o/O/}
+ @cd ${WRKSRC}/src && \
+ ${FIND} * -type d -exec ${MKDIR} "${FOF_DIR}/${PORTNAME:S/f/F/g:S/o/O/}/{}" \; && \
+ ${FIND} -E * -type f -iregex ".*\.(py)" -exec ${INSTALL_DATA} "{}" "${FOF_DIR}/${PORTNAME:S/f/F/g:S/o/O/}/{}" \;
+
+ ${MKDIR} ${FOF_DIR}/data
+ ${LN} -s ${PREFIX}/${DATADIR}/* ${FOF_DIR}/data
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME:S/f/F/g:S/o/O/} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc && \
+ ${FIND} * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}/README
+.endif
+
+post-install:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>