aboutsummaryrefslogtreecommitdiff
path: root/games/frotz/files
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-05-18 04:10:08 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-05-18 04:10:08 +0000
commit18ecf4a8f50885dd5cbdc08307d31fa2d41ca208 (patch)
treeba06afb4047ea08c535a5d35cefbab793d2df90f /games/frotz/files
parent134aef9dc10ee669521481b5b940e70071ee9935 (diff)
downloadports-18ecf4a8f50885dd5cbdc08307d31fa2d41ca208.tar.gz
ports-18ecf4a8f50885dd5cbdc08307d31fa2d41ca208.zip
Import of frotz, yet another Infocom interpreter.
PR: 6660 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=11039
Diffstat (limited to 'games/frotz/files')
-rw-r--r--games/frotz/files/patch-aa38
1 files changed, 38 insertions, 0 deletions
diff --git a/games/frotz/files/patch-aa b/games/frotz/files/patch-aa
new file mode 100644
index 000000000000..205a8fedb898
--- /dev/null
+++ b/games/frotz/files/patch-aa
@@ -0,0 +1,38 @@
+--- Makefile Fri Oct 17 20:11:10 1997
++++ /home/andy/tmp/wrk/Makefile Sat May 16 15:29:57 1998
+@@ -1,7 +1,7 @@
+
+ # Define your c compiler. I recommend gcc if you've got it.
+ #CC = cc
+-CC = gcc
++#CC = gcc
+
+ # Define your optimization flags. Most compilers understand -O and -O2,
+ # Debugging (don't use)
+@@ -43,7 +43,7 @@
+ # have that option.
+ #
+ #DEFS = -DUSE_GETOPT_H -DCOLOR_SUPPORT -DEMACS_EDITING
+-DEFS =
++DEFS = -DCOLOR_SUPPORT -DEMACS_EDITING -DUSE_NCURSES_H -DUSE_NOTHING
+
+ # This should point to the location of your curses or ncurses include file
+ # if it's in a non-standard place.
+@@ -57,7 +57,7 @@
+ #CURSES = -lncurses
+ #LIB = -L/5usr/lib
+ LIB =
+-CURSES = -lcurses
++CURSES = -lncurses
+
+ # Nothing under this line should need to be changed.
+
+@@ -66,7 +66,7 @@
+ text.o ux_init.o ux_input.o ux_pic.o ux_screen.o ux_sample.o \
+ ux_text.o variable.o
+
+-CFLAGS = $(OPTS) $(DEFS) $(INCL)
++CFLAGS+= $(DEFS)
+
+ frotz: $(OBJECTS)
+ $(CC) -o frotz $(OBJECTS) $(LIB) $(CURSES)