aboutsummaryrefslogtreecommitdiff
path: root/games/funnyboat/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
commit3037cb61c7f1ac5ae9a15cee2365daa2d4036028 (patch)
treee391a5b5894d27043bb95bd6680b03174979f810 /games/funnyboat/Makefile
parent28eb882aa04c420b3fe972dd8748b80c90c5cd82 (diff)
downloadports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.tar.gz
ports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful
Notes
Notes: svn path=/head/; revision=321181
Diffstat (limited to 'games/funnyboat/Makefile')
-rw-r--r--games/funnyboat/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/games/funnyboat/Makefile b/games/funnyboat/Makefile
index 44bed69b6a50..a2f1212d760f 100644
--- a/games/funnyboat/Makefile
+++ b/games/funnyboat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: funnyboat
-# Date created: 18 Mar 2007
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= funnyboat
PORTVERSION= 1.5
@@ -28,6 +24,8 @@ SUB_LIST= PROGRAM_DIR="${PREFIX}/lib/${PORTNAME}"
PORTDOCS= README.txt
+.include <bsd.port.options.mk>
+
do-install:
${MKDIR} ${PREFIX}/lib/${PORTNAME}
${MKDIR} ${PREFIX}/lib/${PORTNAME}/data
@@ -35,8 +33,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/data/* ${PREFIX}/lib/${PORTNAME}/data
${INSTALL_SCRIPT} ${WRKDIR}/funnyboat_ ${PREFIX}/bin/funnyboat
-.if !defined(NOPORTDOCS)
post-install:
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}