aboutsummaryrefslogtreecommitdiff
path: root/games/gcompris-qt
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2022-05-11 15:09:53 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2022-05-12 09:55:22 +0000
commit0126809d2b89f13f2ec3b8e4afab5b4f856e248c (patch)
treea619000e4098e8bb717943b109e1a86e585bd966 /games/gcompris-qt
parent8db2f1e8149b09a442c62b7576db48c3498e1c90 (diff)
downloadports-0126809d2b89f13f2ec3b8e4afab5b4f856e248c.tar.gz
ports-0126809d2b89f13f2ec3b8e4afab5b4f856e248c.zip
games/gcompris-qt: add runtime dependency on Qt5 imageformats
It (Qt5 imageformat) is not needed for the build, but is loaded at runtime for some of the images / movies in the game. Reported on the KDE distributions@ list.
Diffstat (limited to 'games/gcompris-qt')
-rw-r--r--games/gcompris-qt/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/gcompris-qt/Makefile b/games/gcompris-qt/Makefile
index 2fa2590826ee..9b91e37bc00b 100644
--- a/games/gcompris-qt/Makefile
+++ b/games/gcompris-qt/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gcompris-qt
DISTVERSION= 2.4
+PORTREVISION= 1
CATEGORIES= games education kde
MASTER_SITES= http://gcompris.net/download/qt/src/
@@ -17,7 +18,8 @@ USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
USE_KDE= doctools_build ecm_build
USE_QT= core declarative graphicaleffects gui multimedia network quickcontrols \
sensors svg widgets \
- buildtools_build linguisttools_build qmake_build testlib_build
+ buildtools_build linguisttools_build qmake_build testlib_build \
+ imageformats_run
CMAKE_ARGS= -DQML_BOX2D_LIBRARY=${QT_QMLDIR}/Box2D.2.0