aboutsummaryrefslogtreecommitdiff
path: root/games/gcompris-qt
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-11 18:27:58 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-11 18:53:25 +0000
commitffde39a7aa1df1378c157d629b238fba3d21705f (patch)
tree0d885c9474ded69c0c82000407ac9738b1a8189f /games/gcompris-qt
parent52ea7e5752d802979b5a33f7e7f96d9de99bb3bb (diff)
downloadports-ffde39a7aa1df1378c157d629b238fba3d21705f.tar.gz
ports-ffde39a7aa1df1378c157d629b238fba3d21705f.zip
games/gcompris-qt: fix build due to missing build-deps
Diffstat (limited to 'games/gcompris-qt')
-rw-r--r--games/gcompris-qt/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/gcompris-qt/Makefile b/games/gcompris-qt/Makefile
index 81261d1697a7..4439d68a7385 100644
--- a/games/gcompris-qt/Makefile
+++ b/games/gcompris-qt/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gcompris-qt
DISTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= games education kde
MASTER_SITES= http://gcompris.net/download/qt/src/
@@ -14,10 +15,10 @@ LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING-GPLv3
LIB_DEPENDS= libBox2D.so:x11-toolkits/qml-box2d
USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
-USE_KDE= doctools
+USE_KDE= doctools_build ecm_build
USE_QT= core declarative graphicaleffects gui multimedia network quickcontrols \
sensors svg widgets xml xmlpatterns \
- buildtools_build linguisttools_build qmake_build
+ buildtools_build linguisttools_build qmake_build testlib_build
CMAKE_ARGS= -DQML_BOX2D_LIBRARY=${QT_QMLDIR}/Box2D.2.0