aboutsummaryrefslogtreecommitdiff
path: root/games/gcompris
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-07-24 16:13:24 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-07-24 16:13:24 +0000
commitfa8fb0a8f285347e7188b1bb05a116d62dac6cc1 (patch)
treebf30628fe7d5a8101a8382ba8de5d0ed6636f58b /games/gcompris
parent525e48653d72a7a43775eab1a90bdb73dbaf29de (diff)
downloadports-fa8fb0a8f285347e7188b1bb05a116d62dac6cc1.tar.gz
ports-fa8fb0a8f285347e7188b1bb05a116d62dac6cc1.zip
Various fixes and cleanups:
- Handle pthread and installation dirs issues using perl regex instead of patches; - add gnomecc RUN_DEPENDS to ensure correct removal; - make it buildable even w/o autoheader installed.
Notes
Notes: svn path=/head/; revision=30998
Diffstat (limited to 'games/gcompris')
-rw-r--r--games/gcompris/Makefile6
-rw-r--r--games/gcompris/files/patch-ac30
2 files changed, 20 insertions, 16 deletions
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index a716b06cdda0..354da2b831c4 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/share/automake/install-sh:${PORTSDIR}/devel/automake
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -32,5 +33,10 @@ CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
post-extract:
@${LN} -sf ${LOCALBASE}/share/automake/install-sh ${WRKSRC}/install-sh
@${LN} -sf ${LOCALBASE}/share/automake/mkinstalldirs ${WRKSRC}/mkinstalldirs
+ @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/pixmaps|\$\(datadir\)/gnome/pixmaps|g ; \
+ s|\$\(datadir\)/sounds|\$\(datadir\)/gnome/sounds|g ; \
+ s|\$\(localstatedir\)/games|\$\(datadir\)/gnome/games|g'
.include <bsd.port.mk>
diff --git a/games/gcompris/files/patch-ac b/games/gcompris/files/patch-ac
index a158f56775d4..a58c73ac522d 100644
--- a/games/gcompris/files/patch-ac
+++ b/games/gcompris/files/patch-ac
@@ -1,17 +1,15 @@
---- Makefile.in.orig Thu Jul 20 03:19:15 2000
-+++ Makefile.in Fri Jul 21 18:32:23 2000
-@@ -114,11 +114,11 @@
-
- SUBDIRS = intl po macros src sounds
-
--pixmapdir = $(datadir)/pixmaps/gcompris
--icondir = $(datadir)/pixmaps
-+pixmapdir = $(PACKAGE_PIXMAPS_DIR)
-+icondir = $(PIXMAPS_DIR)
- soundlistdir = $(sysconfdir)/sound/events
- Gamesdir = $(datadir)/gnome/apps/Games
--scoredir = $(localstatedir)/games
-+scoredir = $(SCORE_DIR)
-
- leveldatadir = $(datadir)/gcompris/data
+--- Makefile.in.orig Mon Jul 24 19:02:08 2000
++++ Makefile.in Mon Jul 24 19:02:52 2000
+@@ -178,9 +178,9 @@
+ rm -f $(srcdir)/stamp-h.in; \
+ $(MAKE) $(srcdir)/stamp-h.in; \
+ else :; fi
+-$(srcdir)/stamp-h.in: $(top_srcdir)/configure.in $(ACLOCAL_M4) acconfig.h
+- cd $(top_srcdir) && $(AUTOHEADER)
+- @echo timestamp > $(srcdir)/stamp-h.in 2> /dev/null
++#$(srcdir)/stamp-h.in: $(top_srcdir)/configure.in $(ACLOCAL_M4) acconfig.h
++# cd $(top_srcdir) && $(AUTOHEADER)
++# @echo timestamp > $(srcdir)/stamp-h.in 2> /dev/null
+
+ mostlyclean-hdr: