aboutsummaryrefslogtreecommitdiff
path: root/games/ggz-gtk-games/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-03 13:38:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-03 13:38:48 +0000
commit820f2b06b47ae6d806c9a012d64ef88f7e7d4e6e (patch)
treeff2a544fb3b840f9364df3e385255297608d4f59 /games/ggz-gtk-games/Makefile
parent640cd7bf6990131030229e389fb71c0b83062fb7 (diff)
downloadports-820f2b06b47ae6d806c9a012d64ef88f7e7d4e6e.tar.gz
ports-820f2b06b47ae6d806c9a012d64ef88f7e7d4e6e.zip
- Remove NLS option, doesn't build with it disabled
- Fix etc/ggz.modules handling - Drop @dirrm* from plist
Notes
Notes: svn path=/head/; revision=373823
Diffstat (limited to 'games/ggz-gtk-games/Makefile')
-rw-r--r--games/ggz-gtk-games/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/games/ggz-gtk-games/Makefile b/games/ggz-gtk-games/Makefile
index 05d787df5397..279b1b0198ef 100644
--- a/games/ggz-gtk-games/Makefile
+++ b/games/ggz-gtk-games/Makefile
@@ -11,7 +11,7 @@ COMMENT= The GGZ Gaming Zone - GTK+ Games
RUN_DEPENDS= ${LOCALBASE}/bin/ggz-gtk:${PORTSDIR}/games/ggz-gtk-client
-USES= pkgconfig
+USES= gettext pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
@@ -22,12 +22,6 @@ INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-
-NLS_USES= gettext
-NLS_CONFIGURE_OFF= --disable-nls
-
post-patch:
@${REINPLACE_CMD} -e 's|_LDADD =|_LDADD = -lggzcore|' \
${WRKSRC}/chess/Makefile.in \
@@ -50,6 +44,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/reversi/module.dsc ${STAGEDIR}/${PREFIX}/share/ggz/reversi.dsc
${INSTALL_DATA} ${WRKSRC}/spades/module.dsc ${STAGEDIR}/${PREFIX}/share/ggz/spades.dsc
${INSTALL_DATA} ${WRKSRC}/tictactoe/module.dsc ${STAGEDIR}/${PREFIX}/share/ggz/tictactoe.dsc
+ ${RM} ${STAGEDIR}${PREFIX}/etc/ggz.modules
.include "${.CURDIR}/../libggz/bsd.ggz.mk"
.include <bsd.port.mk>