aboutsummaryrefslogtreecommitdiff
path: root/games/ggz-gtk-games/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-02-22 01:31:22 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-02-22 01:31:22 +0000
commit9e09065d1878a8849ce2445240ab683ce9afd430 (patch)
tree598495c700fccfbdcd8ebdc3b6a17c7de27a0150 /games/ggz-gtk-games/Makefile
parentf90f33eaa4d214c0631b97b697901aa721651ddc (diff)
downloadports-9e09065d1878a8849ce2445240ab683ce9afd430.tar.gz
ports-9e09065d1878a8849ce2445240ab683ce9afd430.zip
add ggz-gtk-games 0.0.12
The GGZ Gaming Zone - GTK+ Games PR: 93579 Submitted by: yinjieh@csie.nctu.edu.tw
Notes
Notes: svn path=/head/; revision=156636
Diffstat (limited to 'games/ggz-gtk-games/Makefile')
-rw-r--r--games/ggz-gtk-games/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/ggz-gtk-games/Makefile b/games/ggz-gtk-games/Makefile
new file mode 100644
index 000000000000..7d2efa260db2
--- /dev/null
+++ b/games/ggz-gtk-games/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: ggz-gtk-games
+# Date created: Feb. 19, 2006
+# Whom: yinjieh
+#
+# $FreeBSD$
+#
+
+PORTNAME= ggz-gtk-games
+PORTVERSION= 0.0.12
+CATEGORIES= games
+MASTER_SITES= http://mirrors.dotsrc.org/ggzgamingzone/ggz/%SUBDIR%/ \
+ http://ftp.ggzgamingzone.org/pub/ggz/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION}
+
+MAINTAINER= yinjieh@csie.nctu.edu.tw
+COMMENT= The GGZ Gaming Zone - GTK+ Games
+
+LIB_DEPENDS= ggzcore.8:${PORTSDIR}/games/ggz-client-libs
+RUN_DEPENDS= ${LOCALBASE}/bin/ggz-gtk:${PORTSDIR}/games/ggz-gtk-client
+
+USE_GCC= 3.3+
+USE_GNOME= gnometarget gtk20
+USE_GETOPT_LONG= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --disable-debug
+
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.mk>