aboutsummaryrefslogtreecommitdiff
path: root/games/gl-117/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-09-01 13:30:25 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-09-01 13:30:25 +0000
commit4f02df81341ecf4fcd5ce64aa67f9b04318953c7 (patch)
tree5bfdf1b4aad97bace8a089a61fb93be91e50db5f /games/gl-117/Makefile
parentf7465495ea275820a993bf85d4997d8af271217d (diff)
downloadports-4f02df81341ecf4fcd5ce64aa67f9b04318953c7.tar.gz
ports-4f02df81341ecf4fcd5ce64aa67f9b04318953c7.zip
Add desktop entry
Install man page and documentation Pacify portlint PR: ports/149813 Aprroved by: maintainer timeout (two weeks)
Notes
Notes: svn path=/head/; revision=260365
Diffstat (limited to 'games/gl-117/Makefile')
-rw-r--r--games/gl-117/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/games/gl-117/Makefile b/games/gl-117/Makefile
index 0a73fa6f64da..3548791b2630 100644
--- a/games/gl-117/Makefile
+++ b/games/gl-117/Makefile
@@ -8,10 +8,10 @@
PORTNAME= gl-117
PORTVERSION= 1.3.2
-PORTREVISION= 5
+DISTVERSIONSUFFIX= -src
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/GL-117%20Source
-DISTVERSIONSUFFIX= -src
MAINTAINER= erik@smluc.org
COMMENT= An OpenGL & SDL action flight simulator
@@ -23,4 +23,20 @@ CONFIGURE_ARGS= --with-opengl-dir=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+DESKTOP_ENTRIES= "GL-117" \
+ "Action flight simulator" \
+ "" \
+ "gl-117" \
+ "Game;ArcadeGame;" \
+ false
+
+MAN6= gl-117.6
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/gl-117.6 ${MANPREFIX}/man/man6
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/gl-117.pdf ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>