aboutsummaryrefslogtreecommitdiff
path: root/games/gma/files
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-24 15:04:04 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-24 15:04:04 +0000
commit8f8daf14a39e700fe184c7f1b4e6fe14671e9aa0 (patch)
treeb996e983ec1c9bbf9afea64405022c6ec807c75e /games/gma/files
parentcaca19fd67640de8a0bfe9a744caf766bbc88bbe (diff)
downloadports-8f8daf14a39e700fe184c7f1b4e6fe14671e9aa0.tar.gz
ports-8f8daf14a39e700fe184c7f1b4e6fe14671e9aa0.zip
- Fix build with clang
- Add LICENSE - Switch to PLIST_FILES PR: ports/184905 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=337358
Diffstat (limited to 'games/gma/files')
-rw-r--r--games/gma/files/patch-aa13
-rw-r--r--games/gma/files/patch-apprentice.cc11
-rw-r--r--games/gma/files/patch-configure43
-rw-r--r--games/gma/files/patch-moves.h10
-rw-r--r--games/gma/files/patch-scores.h9
5 files changed, 22 insertions, 64 deletions
diff --git a/games/gma/files/patch-aa b/games/gma/files/patch-aa
deleted file mode 100644
index 9ac4ba9eea9a..000000000000
--- a/games/gma/files/patch-aa
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Makefile.in.old Wed Jul 19 16:44:37 2000
-+++ src/Makefile.in Wed Jul 19 16:45:06 2000
-@@ -58,8 +58,8 @@
- PRE_UNINSTALL = :
- POST_UNINSTALL = :
- AWK = @AWK@
--CXX = @CXX@
--CXXFLAGS = @CXXFLAGS@
-+CXX ?= @CXX@
-+CXXFLAGS += @CXXFLAGS@
- LN_S = @LN_S@
- MAKEINFO = @MAKEINFO@
- PACKAGE = @PACKAGE@
diff --git a/games/gma/files/patch-apprentice.cc b/games/gma/files/patch-apprentice.cc
new file mode 100644
index 000000000000..bce644b27607
--- /dev/null
+++ b/games/gma/files/patch-apprentice.cc
@@ -0,0 +1,11 @@
+--- src/apprentice.cc.orig
++++ src/apprentice.cc
+@@ -32,6 +32,8 @@
+ #include "moves.h"
+ #include "gma.h"
+
++using std::string;
++
+ #define BOARD_SIZE 50
+ #define MAX_DEPTH 2
+
diff --git a/games/gma/files/patch-configure b/games/gma/files/patch-configure
deleted file mode 100644
index 6a881013b68e..000000000000
--- a/games/gma/files/patch-configure
+++ /dev/null
@@ -1,43 +0,0 @@
---- configure.orig Sun May 18 19:14:38 2003
-+++ configure Sun May 18 19:17:02 2003
-@@ -1246,40 +1246,6 @@
- fi
-
-
--ac_safe=`echo "stl.h" | sed 'y%./+-%__p_%'`
--echo $ac_n "checking for stl.h""... $ac_c" 1>&6
--echo "configure:1252: checking for stl.h" >&5
--if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
-- echo $ac_n "(cached) $ac_c" 1>&6
--else
-- cat > conftest.$ac_ext <<EOF
--#line 1257 "configure"
--#include "confdefs.h"
--#include <stl.h>
--EOF
--ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
--{ (eval echo configure:1262: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
--ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
--if test -z "$ac_err"; then
-- rm -rf conftest*
-- eval "ac_cv_header_$ac_safe=yes"
--else
-- echo "$ac_err" >&5
-- echo "configure: failed program was:" >&5
-- cat conftest.$ac_ext >&5
-- rm -rf conftest*
-- eval "ac_cv_header_$ac_safe=no"
--fi
--rm -f conftest*
--fi
--if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
-- echo "$ac_t""yes" 1>&6
-- :
--else
-- echo "$ac_t""no" 1>&6
--{ echo "configure: error: This program requires STL to compile. Sorry." 1>&2; exit 1; }
--fi
--
- ac_safe=`echo "string" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for string""... $ac_c" 1>&6
- echo "configure:1286: checking for string" >&5
diff --git a/games/gma/files/patch-moves.h b/games/gma/files/patch-moves.h
index 285c9e2bff86..cecae223de52 100644
--- a/games/gma/files/patch-moves.h
+++ b/games/gma/files/patch-moves.h
@@ -1,11 +1,13 @@
---- src/moves.h.orig Sun May 18 19:18:04 2003
-+++ src/moves.h Sun May 18 19:18:19 2003
-@@ -24,7 +24,7 @@
+--- src/moves.h.orig
++++ src/moves.h
+@@ -24,7 +24,9 @@
#include "pattern.h"
-#include <stl.h>
-+#include <map.h>
++#include <map>
++
++using std::map;
class Moves:map<Pattern,int>
{
diff --git a/games/gma/files/patch-scores.h b/games/gma/files/patch-scores.h
index dc7dd65e45a3..1195cfaf6461 100644
--- a/games/gma/files/patch-scores.h
+++ b/games/gma/files/patch-scores.h
@@ -1,15 +1,16 @@
--- src/scores.h.orig Mon Apr 17 02:52:22 2000
+++ src/scores.h Sun May 18 19:19:41 2003
-@@ -22,9 +22,11 @@
+@@ -22,10 +22,12 @@
#ifndef SCORES_H
#define SCORES_H
-#include <stl.h>
-+#include <map.h>
++#include <map>
#include <string>
#include "pattern.h"
-+
-+using namespace std;
++using std::map;
++
class Scores
{
+ public: